Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Sep 2006
    Location
    Houston Texas
    Posts
    364
    +1
    10

    pro 785 questions \ help needed

    Hey , just came over from , you know where hello all, Ok have a 97 pro 785 , # 1 , revs only to 6800 rpm( seems to be a common problem on these boats , ) took off seat to check valves ( they work) and ski spun up to 8000 rpm and fast , any ideas ?
    And # 2 very hard to start when warm cranks for about 45 seconds before fires up if it does at all , again any ideas ?
    Also any know of a REAL good mechanic in the Houston area , taht could sort this boat out ?
    Good to be here , thanks for the help


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Whoo Hoo, GREAT to see you!!! I was hoping you'd find your way. Most of the PRO785 guys are here and I'm sure they can answer your question better than I but the first thing I'd check are the exhaust valves. If you need the adjustment procedure I can list it for you.

  3. #3
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    Ex. valves is what I am thinking too or the actuator for the valves? The Pro785 is known for the hard start. The one I briefly rode you had to keep the throttle at 1/4 and it fired up easier. This was a limited set up so a stocker might be different?

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    good to see ya SLOAN check all your exhaust hoses under the storage tray to make sure none have popped . also do a compression check . and make sure those valves open and stay open .

  5. #5
    Mine wouldn't rev out either, but it seemed just as fast. Turns out I have a bad tachometer. I installed a Tiny Tach and it showed I was right under redline..then it broke as Tiny Tach's usually do....

    Aaron

  6. #6

    Join Date
    Sep 2006
    Location
    Houston Texas
    Posts
    364
    +1
    10

    pro 785 questions\help needed

    thanks guys good to be here ! the valves is the first item I checked , all seem to open and close , runs a lot better with the seat off , and revs right up was thinking maybe mixture ? any thought ? could low octane gas cause a hard start problem ? for your info, comp in motor 160 , has a high comp head on and 46 mm redtop carbs , ( ex rouge racing boat ) any know of one of a good mechanic I could send it to in the houston area , again this is a race boat not your typical 785

  7. #7

    Join Date
    Aug 2006
    Location
    western ny
    Posts
    51
    Make sure you dont have any exhaust leaks anywhere, i spent two months chasing a max high of 6800rpm, turned out the gasket between the cylinder and exhaust manifold was leaking a little.. thought no way that tiny leak was doing it, finally pulled it apart repalced the gaskets and BAM right back to 7750rpm.

  8. #8
    Watcon's Avatar
    Join Date
    Oct 2005
    Location
    Seattle WA
    Posts
    872

    785 pro

    I think you better check for a cracked collector, waterbox, exh hose, etc.. He's stating that it runs fine with the seat off.. This usually means the engine compartment is flooded with exhaust fumes, and it can be a small leak that is barely noticable.. Usually an exhaust and/or external pipe leak will be accompanied with water in the hull...

    Vacum all the water out of the hull, and make it perfectly dry inside, then remove the seat, ride it in a straight line only at high rpm and see if you have accumulated water in the hull.. If you have water, then you need to find the possible exhaust/ water leak..

    Randy

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Randy,

    I had one last weekend with a 400 RPM loss and it was pouring smoke like a locomotive, that small a leak will cause a 1K+ RPM loss in a PRO 785?
    Crap I have to start paying closer attention.........

  10. #10

    Join Date
    Aug 2006
    Location
    western ny
    Posts
    51
    Quote Originally Posted by ph2ocraft
    Randy,

    I had one last weekend with a 400 RPM loss and it was pouring smoke like a locomotive, that small a leak will cause a 1K+ RPM loss in a PRO 785?
    Crap I have to start paying closer attention.........
    On mine i couldnt see any smoke, or smell any fumes in the hull at all and it was 1000rpm loss. i would have never guessed that small a leak would do it.... the upper left bolt in my center manifold broke thats what caused my leak to start.. i checked compression, crank phase, had the heads off never found any issues finally when i finally found that small leak after 4-5 weeks of trying everthing from switching props and stators and all sorts of other stuff i decided that was the last thing that it could possibly be and sure enough it was...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ok guys, thinking polaris again... this time pro 785! Questions
    By jcc011185 in forum Polaris PWC Performance
    Replies: 53
    Last Post: 07-30-2007, 08:28 AM
  2. A few Pro 785 questions...
    By hyoctane23 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-15-2007, 11:34 AM
  3. PRO 785 Question
    By tlk25401 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 03-24-2007, 02:13 PM
  4. pro 785 question
    By rgard32 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 12-29-2006, 11:30 AM
  5. Pro 785 questions
    By addicted in forum Polaris Open Discussion
    Replies: 13
    Last Post: 10-24-2006, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •