Results 1 to 4 of 4
  1. #1
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267

    Corrosion on fuses

    I keep getting this white corrosion on the fuses on my RXTX. I go to start it up and it starts, but I get a code and a beep. Shut it off, check the code, clean the guilty fuse, spray some electro cleaner in the fuse box, put fuse back in and it runs fine. First it was the tops sensor, then today one of the coils.
    Anybody know what causes this and how to prevent it.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Cover the fuse prongs & socket with this stuff... and also use it on the fuse cover gasket... done deal!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	31NXSQ9QR9L__SL500_AA300_.jpg 
Views:	295 
Size:	16.5 KB 
ID:	178674  

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Thanks, I will give that stuff a try.

  4. #4
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    i use the same stuff bigdaddy works great now if i could just get my ups driver to look like yours

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Corrosion on fuses
    By troyheb in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-17-2010, 08:32 PM
  2. Removing salt water corrosion on aluminum?
    By rabzman in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-14-2009, 06:47 PM
  3. pump corrosion on the inner surfaces
    By richard kagen in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-05-2009, 06:46 PM
  4. Corrosion on Engine
    By sleaves in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 10-19-2008, 05:22 PM
  5. Corrosion on FXSHO engine parts!!!!!!!!
    By doublerkid in forum Yamaha PWC Performance (4-stroke)
    Replies: 42
    Last Post: 09-12-2008, 02:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •