Page 1 of 12 1 2 3 11 ... LastLast
Results 1 to 10 of 112
  1. #1

    1996 GSX won't rev above idle

    Here's the story.......come from sleds and bikes, bought this GSX for cheap, has rebuilt engine, starts and idles fine, but as soon as gas is applied it bogs and backfires..........so far this is what I have done:

    Changed all tempo fuel lines to new lines.
    Clean/lubed fuel selector valve
    Verified both hull vents operational(outlet one was plugged)
    Cleaned/checked carbs(they were actually quite clean)
    Popoff checked, all passages cleaned.
    Pulled "red" wire on rectifier.......no change
    Changed gapped/plugs
    Cut back plug wire 1/4 inch
    Di-electric grease on most connections
    Pulled rotary cover and verified valve timing.....

    I'm kind of at a loss..........I'm sure what else to check, its seems like it is fuel related since it bogs and then backfires.........but I'm not sure what it could be.......would water in fuel cause this? Bad fuel? I'm open to anything..........!!
    I'm just waiting on a new rotary cover o-ring and carb gaskets to put it back together............


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Welcome to GH crazy!

    You have done good so far. Does the gas smell old? It is certainly a possibility. This engine very seldom backfires. So I would siphon out the old and start with the easy stuff first.

  3. #3
    Petron's Avatar
    Join Date
    Aug 2008
    Location
    Boston
    Posts
    923
    +1
    1
    Quote Originally Posted by crazeejames View Post
    Here's the story.......come from sleds and bikes, bought this GSX for cheap, has rebuilt engine, starts and idles fine, but as soon as gas is applied it bogs and backfires..........so far this is what I have done:

    Changed all tempo fuel lines to new lines.
    Clean/lubed fuel selector valve
    Verified both hull vents operational(outlet one was plugged)
    Cleaned/checked carbs(they were actually quite clean)
    Popoff checked, all passages cleaned.
    Pulled "red" wire on rectifier.......no change
    Changed gapped/plugs
    Cut back plug wire 1/4 inch
    Di-electric grease on most connections
    Pulled rotary cover and verified valve timing.....

    I'm kind of at a loss..........I'm sure what else to check, its seems like it is fuel related since it bogs and then backfires.........but I'm not sure what it could be.......would water in fuel cause this? Bad fuel? I'm open to anything..........!!
    I'm just waiting on a new rotary cover o-ring and carb gaskets to put it back together............
    Welcome to greenhulk.

    Did you check your fuel filter?

    Also, your baffle (pickup situated inside your fuel tank) has a screen filter on the bottom & it could very well be plugged.

    See Items 20 & 22. I'm willing to bet that screen filter has never been inspected &/or replaced.

    Does your gas tank look dirty?

  4. #4

    thanks guys

    thanks, I'm going to connect a fuel line out to a jerry can to isolate the fuel system.......I work all weekend, so might not happen till monday though
    Do I have to pull the tank to get that strainer out? It was b*tch of a job getting to all the lines on that thing!
    Thanks again, I'll update as soon as I check anything.

  5. #5
    Petron's Avatar
    Join Date
    Aug 2008
    Location
    Boston
    Posts
    923
    +1
    1
    Quote Originally Posted by crazeejames View Post
    Do I have to pull the tank to get that strainer out? It was b*tch of a job getting to all the lines on that thing!
    You don't have to pull the gas tank out but you will have to take your handlebars off in order to pull the baffle up & out of the tank - unless you get lucky somehow

    Ensure your fuel filter is clean though, obviously easier to check that first & as Rob suggested, check/ smell your fuel, siphon the tank.

  6. #6

    Fuel filter

    By fuel filter, or you meaning the sediment type one in the hull? Or the carb filters? Carb filters are spotless, sediment is clean, o-ring in properly........
    Thanks

  7. #7
    Petron's Avatar
    Join Date
    Aug 2008
    Location
    Boston
    Posts
    923
    +1
    1

  8. #8

    filter

    Oh yeah, that filter is clean, there is an inner and an outer, both are spotless. When I changed hoses, I could blow thru the "head" freely.
    Thanks for the clarification though.

  9. #9
    I read this same issue from another site and the guy solved the issue by installing a new coil assembly. He also said it started doing it shortly after he flipped it. New coil is 100 bucks.

  10. #10
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    MY .02, only suggestions: sounds like you have covered alot of probable issues that most would try first me included..i would take a look at the coils along with fresh plugs,if not that i would the magneto keyway to see if it has sheered and slipped on the shaft and maybe upset the timing a bit?

Page 1 of 12 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 Sea-Doo GSX Limited 951 - Won't rev above 3200 rpm - HELP
    By mbushnell in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-28-2016, 03:47 PM
  2. 2000 GP800R Won't Rev above 3-4K RPM
    By Raider3 in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 08-08-2010, 10:56 AM
  3. 96 SL 780 won't rev above 2500 rpm
    By twinSL780s in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-05-2009, 10:07 PM
  4. GSX won't rev all the way up
    By DTH357 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 09-03-2009, 11:44 AM
  5. 2002 GTX DI won't run above idle in water
    By zone 5 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-26-2007, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •