Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555

    SL750-780 new motor first test

    So I took the SL out today for the first time, ran pretty good. Got around the lake once then my steering cable broke, so I'm looking for another (the bigger, longer one). The extension I put on there didn't quite hold up, and broke by the end of the threads. I looked at the 95 cable and its a lot bigger than the 94. The water box sure made it sound snappy! Now my big questions is, I have a power surge at around 4000 RPMs. I'm running the 780 impeller with the 780 motor, have the extended pump and ride plate, and 4 degree wedge. I have also boosted the compression to about 150 and cut out the choke butterflies and installed primer. and I have the v-force 2 reeds and vortec flame arrestors. Should this be around when the majority of the power kicks in? I haven't held it wide open yet since I'm still in the break in period, but its very noticeable and it happens whether I'm on a plane or not. Also notice a significant amount of water in the hull, which I will track down next time I bring it to the lake. I still have the 750 carbs, and am thinking it might be jetting? I know keyzbum had rejetted them for the 780 but I've got a lot of things I've changed. I should have tried opening the low end jets but the steering cable had me distracted.


  2. #2
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    Oh and I have the pro 785 cdi in it too all I need is tripple pipes and I'd be stylin'
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	sl750 first.jpg 
Views:	64 
Size:	41.0 KB 
ID:	179035  

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    The PRO CDI, raised compression, aftermarket waterbox, and V Force reeds all should help acceleration.

    It's not unusual for the engine to get on the pipe around 4k RPM.

    I guess I'm not following what you're really asking.

    Have you read the carb tuning for girls posted by Watcon in the tech section? I guess that would help you determine if you're having a jetting issue at take off. Plug chops, piston wash, and tachometer readings will help determine if high speed jetting is correct.

  4. #4
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    I guess I had a few too many when I wrote that post .. but yea I need to fix the steering cable and get it out again, then check jetting. I read the carb tuning for girls awhile back maybe its time for a refresher

  5. #5
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Great to hear Toby
    like kevin said --LOOK at the piston wash and go from there..
    That waterbox sounds good -dont it?
    Just think next time you come to ride you wont have a couch

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Quote Originally Posted by FLjoyrider View Post
    I guess I had a few too many when I wrote that post .. but yea I need to fix the steering cable and get it out again, then check jetting. I read the carb tuning for girls awhile back maybe its time for a refresher
    Got a few here if you need one.

  7. #7
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    Took it out again today for a good hour. I checked my high speed screws and they were 2 turns out!! that would explain the excess smoke I had on my first test ride( wondering where I got that number while assembling..). I adjusted them to about 1/4 turn and that seems pretty good. Low speed screws were at 1 1/8 and I turned them out to 1 1/4. (I'm running the 750 carbs with no choke plates) I did manage to make a better extension on the steering cable which held up good. Still might want to upgrade to the thicker one. Max RPMs after a couple hours break in when I finally felt comfortable with wide open was 6720 which I don't think is too bad. It has a 96 SLT780 impeller in it. Speedometer hit 54mph (dreamometer?) take off is great it hesitates for a second tho now that I adjusted the low speed screws out so I'll lean them a tad, then maybe richen the highs a bit too. I also got an overheat towards the end of the day which is probably due to me beaching it a couple times.. didn't feel too hot to the touch tho, I could hold my hand on the cylinders for a good 3 seconds before I had to pull away. I'm going to pull the heads check wash, install the pissers and see if theres any sand in the cooling system. I also need to replace the bearing on the through hull fitting since its leaking . All in all it went very good just some minor things to work out. Can't wait to abuse it some more next weekend

  8. #8
    It's a JEEP thing...You wouldn't Understand dirtdude35's Avatar
    Join Date
    May 2009
    Location
    Hurst tx
    Posts
    473
    what water box are you using?

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    What's your set up?

    A SL 780 with a 1996 SLT 780 impeller? (15/20)

    V Force reeds

    High compression heads

    PRO 785 CDI

    And an aftermarket waterbox?

  10. #10
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    Heres what I've got:

    SBT pistons
    SBT crank
    SBT seals + gaskets
    SBT carb kits
    V-force 2 reeds
    V-force reed spacers
    vortec flame arrestors
    choke plates removed and plugged
    machined domes ~ 150 psi
    97 785 CDI
    4" pump extension (before impeller)
    modified SLT ride plate (cut thinner to fit the 94 SL)
    primer
    variable oil injection pump
    750 cases with 780 cylinders
    tripple outlet fuel pump
    750 electrical stator
    BPR8es plugs.. thinking I need to get some regular BR8es ones
    Aftermarket water box - have to ask keys which brand it is the label is gone
    pissers - doing those this week sometime

    update - pulled the heads, center cylinder looks good, two outers are looking lean but were wet n sticky on the tops of the pistons? I'll post some crappy pics (with my phone) when I get home tonight.

    I know, BST isn't the greatest, but they give me a sweet discount
    Last edited by FLjoyrider; 03-29-2010 at 02:11 PM. Reason: SBT explanation...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 12-24-2015, 11:19 PM
  2. First test on new 2014 FZR
    By 2fast4u in forum Yamaha PWC Performance (4-stroke)
    Replies: 16
    Last Post: 12-22-2013, 09:35 AM
  3. First test ride results on RXP after new mods...
    By JAG in forum 4-Tec Performance
    Replies: 44
    Last Post: 12-24-2006, 08:30 PM
  4. gpr first test
    By thirdgen327 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-26-2006, 11:30 AM
  5. First test with 2 Intercoolers Need Some Impeller Help!
    By somefun in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2006, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •