Results 1 to 5 of 5

Thread: Hi temp in chop

  1. #1

    Join Date
    Dec 2007
    Location
    Yorktown, VA
    Posts
    267
    +1
    9

    Hi temp in chop

    I have 05 rxp with a stage 2 kit when i go thru chop at full speed and trim is near the top the hitemp light comes on but if the trim is down it does not seem to happen any help would be great


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    If you are coming unhooked a lot, you are catching air in the driveline...which pumps air into the cooling system...which will develope air pockets...and when these pockets hit the Jpipe, they interupt waterflow for a second...thus the temp sensor sees HOT EXHAUST, not exhaust/water mix...

    Thats why you never see it in trim down position, because you are most likely constantly hooked up...

    My advice, unless you have a wedge installed...1-2 clicks above neutral is the highest you should go, thats the sweet spot

  3. #3

    Join Date
    Dec 2007
    Location
    Yorktown, VA
    Posts
    267
    +1
    9
    thanks 4 the info i do not have a wedge on my ski. do u think the wedge makes a difference

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    The wedge is used mostly for skis that do not have VTS, but can help the hendling of an RXP...Wedge riding is rider depndant, how you sit/stand ont he ski at speed will affect the handling...So the wedge is a personal preference.

  5. #5
    Tampa SeaDoo Crew TampaSpeedster's Avatar
    Join Date
    Sep 2009
    Location
    Tampa, FL
    Posts
    95
    Try getting a better intake grate to keep you in the water during choppy conditions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Hi temp warning
    By Bambeezer in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-30-2014, 09:15 PM
  2. hi temp problem
    By MONKEY in forum 4-Tec Performance
    Replies: 24
    Last Post: 07-12-2006, 09:47 PM
  3. Hi temp warning...
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-27-2006, 02:06 PM
  4. Hi temp warn, engine or ? bubbling
    By Hecyan in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-26-2006, 06:09 PM
  5. 04 RXP Riva STG II Hi-Temp Alarm
    By ramnj in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-16-2006, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •