Results 1 to 7 of 7
  1. #1

    96 xp blows fuse as soon as it runs

    I have a 1996 seadoo xp. Just rebuilt the motor, new crank and pistons. I replaced the fuel lines and power valve boots and springs. Starter seemed like it was having a hard time starting the motor. I took the started apart and cleaned the connections and the part of the armature where the brushes sit. Put the starter back on and it seemed to help. Long story short, the jet ski will start, but as soon as it starts it blows the 5 amp fuse that comes of the the positive side of the starter soleniod. Looked at the wire diagram and it looks like the 5 amp fuse going to the red wire with purple tracer goes to the fuel, battery, temp, oil guage. Since it keeps blowing it I know it is a dead short somewhere, but what could be causing the dead short only when the jet ski cranks up and runs for about 1 second? My first idea is the temp sensor on the head. But the ski won't do anything with the sensor unplugged because it provides ground for something. Anybody have any ideas? I appreciate any help?


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    you need to check your stator. theres probably metal shavings in the mag cup or the stator fried.

    sorry to say, this means removing the front mag cover, which is a PITA to do in the ski. to do it, you need to put a 2x4 under the motor to hold it up and remove the front mount. then its pretty straight forward from there.

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Yes, pull the front cover to check the stator. Check the inductive pickup for breakage on the ears too when you have it out.

  4. #4
    How do I tell if the stator is fried? Probably going to tear it back apart next weekend. Can I continue to ask questions on this thread? Probably going to work on it next weekend when I have some free time. I really appreciate the help. I would have never thought to look there for problems.

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Sure! That's what this thread is for. Reference this thread for great pics and info, I included the page with pics.

    http://www.greenhulk.net/forums/show...ctifier&page=4

  6. #6
    hey got a chance to pull the cover off tonight. I have some metal shavings on the magneto, pickup, and magnet on the flywheel. Is this what you guys where referring to or do I need to remove the flywheel to inspect the stator. I found a stator test in a service manual but it calls for some adapter plug that goes to the plug in on the front of the motor so you can check the resistance on the yellow wire. Also is it possible to clean or repair any of the parts without having to replace them.
    Thanks for the help,
    Austin

  7. #7
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Air. Blow high pressure to dislodge the metal shavings. The stator is mounted on the front cover. Refer to the thread I mentioned for color inspection of the stator coils.

    Post up pics if you like.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP Blowing Fuel when plugs are out
    By Tesler32 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-22-2015, 09:26 AM
  2. 96 XP Buzzer won't stop but ski runs great
    By Spimothy Leary in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 11-01-2011, 01:07 PM
  3. 96 XP Keeps Blowing Fuse
    By drewkeen in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-29-2011, 02:50 PM
  4. 96 SPI blowing fuses
    By Milo172 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-05-2010, 07:47 PM
  5. 96 Xp Starter spins as soon as DESS Lanyard
    By xxbusa in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-17-2009, 07:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •