Results 1 to 2 of 2
  1. #1

    A few questions...

    1. My RXP05 has been docked in the water for 4 nights (drove it all 4 days) now and when I got it on the trailer, I found about 1" of water in the hull, what could of got this water inside? I was probably thinking around the ride plate there is a black sealant around it, and I thought maybe it came from there.. so what could of caused this?

    2. I can not get hold of SAE 10w-40 oils , so I use Mobil1 0w-40 oil, is this fine?

    Thanks in advance.


  2. #2

    Join Date
    Jul 2005
    Location
    Coral Springs
    Posts
    84
    1 inch of h2o prob. just from 4 days of use.

    If you want to check for a leak put it on the trailer and tilt it back and fill with water up to the drive shaft seal and look for leaks.

    Or dry it out and back it in on the trailer to hold it down and look for leaks with a flashlight.


    If it’s synthetic oil its no good! You must use non-synthetic oil in the supercharged units!
    Damm'it read the manual!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Soon to buy an rxp a few questions though
    By red rider in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 10-12-2006, 10:01 PM
  2. G-Hulk I have a few questions (SKEGS!)
    By FireFox in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-31-2006, 04:26 PM
  3. about to buy 06 rxp, have few questions before I buy
    By CarFanatic in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 05-30-2006, 07:35 PM
  4. A few questions about my RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-28-2006, 02:22 AM
  5. Just a few questions.
    By Ed in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-24-2005, 09:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •