Results 1 to 7 of 7
  1. #1

    seadoo xp 96 non runner

    hey guys bought my self a seadoo xp 96 the other night as a non runner. been left for 18 months. now no spark was running before left.
    turns over but no spark. i think it might be the coil but im not quite sure. i have a owners manaul for it.
    i have checked all the wiring. removed the starting motor cleaned all wires earths. removed the mpem cleaned loads of wires checked all fuses.. i get the BLEEP BLEEP when i put the lanyard in and shes turning over.. does anyone no what vols i need at the white wire on the coil when im cranking over?

    any help would be great..


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Welcome to GH!

    Make sure the small black wire is also hooked to ground on the battery post, a mistake most all of us have made.

  3. #3
    thats on... i think its the coil give up but i just want to check its gettin the volts from the trigger coil. so i need to find out what the volts should be at the white wire at the side of the coil

    thanks for the help.

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Check the ground post at the bottom of the black box that retains the coil. If water has gotten in it corrosion could be preventing it. Also, remove the white and black wires off the connectors to the ignition coil and check for corrosion there. Then remove the top plug to the box, and check all pins for corrosion too. The coils are very reliable. The inductive pickup could be broken under the front cover of the engine too.

  5. #5
    i have done this but im goin to do it again.
    i will also clean up the posts on the coil aswell again..
    its only done 50ours from band new. so i didnt think theres alot wrong with it
    how can i find out what the voltage is ment to be at the white wire at the side of the coil when im cranking? as this will rule out all wiring problems if i have the right voltage at the coil. i will also clean the earth wires at the coil. i thought it must be a wire brokin because every plug on the ski as green inside it. i have been cleaning them out.

  6. #6
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    a weak battery will also cause no spark. the battery might have enough juice to turn it over, but there will be no spark. i believe you need somewhere around 12.3V to get spark.

  7. #7
    its got 12 40 every time.. im thinking of replacing some of the wiring onit a new earth wire and some of the earth wires in the box with the coil because they are 14 years old.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo xp 96 no spark and no beeps
    By mayers1982 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-22-2013, 06:19 PM
  2. Seadoo XP '96 - wont turn over after 4-5 starts
    By Lurch in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-09-2012, 02:22 PM
  3. 1996 Seadoo Xp 800 Non-Starting (Video Inside)
    By 2blue in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-24-2012, 06:05 AM
  4. seadoo xp 96 787
    By 306kev in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 11-02-2010, 03:00 AM
  5. going to look at a 96 seadoo xp
    By gorilla03 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-08-2007, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •