Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 46

Thread: wow need help

  1. #1

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715

    wow need help

    i looked under my ski and this is what i saw, plate has 1 hour on it. should riva cover this
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	intake broke 001.JPG 
Views:	82 
Size:	1.33 MB 
ID:	179651   Click image for larger version. 

Name:	intake broke 002.JPG 
Views:	71 
Size:	1.36 MB 
ID:	179652   Click image for larger version. 

Name:	intake broke 003.JPG 
Views:	85 
Size:	1.34 MB 
ID:	179653   Click image for larger version. 

Name:	intake broke 004.JPG 
Views:	64 
Size:	1.26 MB 
ID:	179654  


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    sorry to see that.
    To many times for me..

    Is the grate intake, did it pull the other bolts out??

  3. #3

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    what do i do

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by stevorxp007 View Post
    what do i do
    Replace it with the x plate you have for sale and brng it to rivas attention.

  5. #5

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    x plate wont fit my ski any other idea

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by stevorxp007 View Post
    x plate wont fit my ski any other idea
    It sure will. I've got one on my 06 right now. Just need to cut the 2 plastic bosses from the pump shoe being that all three bolts will go into the plate.

  7. #7

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    ok but i still cant take a hit like that riva has to do something right, its 1 hour wow

  8. #8

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    and yea it pulled out the other 2 inserts

  9. #9
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Good luck convincing Riva on the plate. The issue was the brass inserts pulling out on you that caused the rear mounting tab to brake. Your lucky that the intake grate didnt snap in two. Pull the grate and inspect for cracks. I've seen this over and over again. Dont waste your time epoxing those inserts in there again. They will pull out again. Brotherman you have 2 choices here.... replace the pump shoe and plate or do a rigging job much like Jeremy whos going thru this same situation as we type. This happened to me, Gus , Caldo101, Doel, Terry, Jim, and Jeremy and these are just the ones I know about. read the last 5-6 pages of Jeremys thread. http://www.greenhulk.net/forums/showthread.php?t=61053
    good luck bro. !!!!!!!!!

  10. #10
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    Stevo.......

    Don't waste your time with Riva. Kc is right it happen to all of us. I had about 3 hours in my plate. Robert(Caldo101) and I came up with the perfect fix and you don't have to buy another plate. Its about a six hours project but will work great. I still running my grate, plate without no issue or problems. Its a strong fix! I wish had some pics of this project. I know now will help lots of members with this issue. I'm going to ge with Robert, Kc and see if we can come up with a video or pic's in how to do this project. Sorry about your new plate!

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 25
    Last Post: 07-06-2011, 12:24 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •