Results 1 to 8 of 8
  1. #1

    Another Polaris Virage (Yongwang) PROBLEM!!!

    hi guys got ready to go out for a ride on my ski today and found that ski wouldnt start. ( it tries to turn over but it wouldnt) Anyway i checked the spark plugs, they were routed so went and bought some. After that still no go

    so i sprayed abit of the aero start and yeah it got it going and off i went. 10 mins later i here a weird noise, and when i hit the throttle to go faster its sounds like loosing petrol so i went back to shore and turned it off

    after that, ski wont start again so me and my father in law open the carby where the air filter is and was pressing the throttle and realise there was no petrol was going in. Anyone know whats wrong???

    we thought that the fuel filter was stuffed, so we went and bought one after we installed it, we realise that there was no fuel going in the air filter? does this yongwang polaris copy have fuel pump?

    we took one of the hose out to feel if its sucking, but no go. Has anyone here no whats wrong?? pic here
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1040316_resize.JPG 
Views:	103 
Size:	132.7 KB 
ID:	180359   Click image for larger version. 

Name:	P1040310_resize.JPG 
Views:	78 
Size:	143.5 KB 
ID:	180360   Click image for larger version. 

Name:	P1040309_resize.JPG 
Views:	73 
Size:	124.9 KB 
ID:	180361  


  2. #2
    more pic if this help
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1040308_resize.JPG 
Views:	72 
Size:	123.1 KB 
ID:	180362   Click image for larger version. 

Name:	P1040311_resize.JPG 
Views:	99 
Size:	123.0 KB 
ID:	180363  

  3. #3

    Join Date
    Sep 2008
    Location
    Sweden
    Posts
    80
    Yes it has a mechanic fuelpump, its attatced to the carburator, its a membrane-pump.

    Im not a good mechanic but check the membranes in the fuelpump, check for airleaks, also check the line going to the crankcase.

    airleaks can be the problem...

    another problem last summer for me was a bad membrane in the carburator. what happend sounded like your story but no problem getting fuel to the carb.

    used a rebuild kit and then it worked. (if you buy a carbrebuildkit, this includes the fuelpumpmembranes and gaskets and the carburator membrane and gaskets. also some other stuff :P)

  4. #4
    As posted above, there's an accelerator pump that is "powered" by the vacuum pulse line coming from the crank cases.

    1st, make sure your battery is fully charged

    Then, I'd pull the carbs, check the pump and check the jets for any foreign debris. Might be time for a carb rebuild.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    The fuel pump is powered by a hose connected to the crank case, below the carburetor. Make sure that 'pulse hose' is not loose, kinked, or damaged.

    The accelerator pump in the carburetor, if it has an accelerator pump, is controlled by the throttle lever.

    This machine is a Polaris copy, not a genuine Polaris, so many of the details can be different.

    zephyrlius had to repair the carburetor in his Yong Wang - this carburetor may have the same problem.

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Quote Originally Posted by zephyrlius View Post
    Yes it has a mechanic fuelpump, its attatced to the carburator, its a membrane-pump.
    Does this carb look like the carb on your PWC ?

    From what I can see, it does not look like the Keihin-CDK II carb that Polaris used.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by casey67 View Post
    ...From what I can see, it does not look like the Keihin-CDK II carb that Polaris used.
    Another Yong Wang owner (zephyrlius) posted this;

    Polaris virage idle problem

  8. #8

    Join Date
    Sep 2008
    Location
    Sweden
    Posts
    80
    no, the carb looks different to mine.

    maybe you need to find the chinese-parts-dealer.

    or find out what carb it is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CArby problem on polaris virage (yongwang)
    By filopola in forum Polaris Open Discussion
    Replies: 20
    Last Post: 09-24-2010, 08:07 AM
  2. Polaris virage idle problem
    By zephyrlius in forum Polaris How To & FAQs
    Replies: 34
    Last Post: 04-03-2010, 10:51 PM
  3. 2001 polaris virage electrical problem
    By notbradparker in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-04-2009, 02:09 PM
  4. 2001 Polaris Virage starting problems
    By scotty771 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 07-22-2008, 10:12 PM
  5. Polaris Virage Starting Problems...
    By Goliath in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-21-2008, 09:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •