Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2010
    Location
    Pierre Part, LA
    Posts
    43

    Exclamation 2008 Ultra 250x Crazy Problem-Makes no sense.

    I have a 2008 Ultra 250x Crazy Problem. It runs fine about 90% of the time. Every once in a while after running great it seems to "drop" a spark plug. Max RPM is about 6700 when this happens. I can immediately turn it off and start it again and it will run fine. It seems to happen most after idling through a no wake zone. I have replaced the spark plugs numerous times and it still does this. This machine has less than 50 hours on it. I have another 2008 Ultra 250x with no problems at all. Is this an ECM, Coil Pack, Fuel Injector, etc issue? The dealer is as stumped as I am. Any help would be greatly appreciated.


  2. #2
    H20 addicted Blu_Boost's Avatar
    Join Date
    Sep 2008
    Location
    Lake Havasu,AZ
    Posts
    302
    The dealer shouldnt be stumped.... or i wouldnt allow them to be stumped if you have warranty. I had fuel injection issue but it wasnt giving any codes on the dash. Dealer couldnt figure out the problem after multiple visits and still experiancing the same problem. I just made sure it was on record that their was a problem in case it cuased a major issue in the fututre. Finally got FI code in dash and took it to dealer and they somehow fixed it and told me it was a loose wire within the fuel injection. I know this probaly doesnt resolve your problem just sharing my experiance with a "stumped" dealership.

  3. #3

    Join Date
    Mar 2010
    Location
    Pierre Part, LA
    Posts
    43

    Exclamation

    The Dealer has been pretty good as I am still in my factory warranty and I did buy the GTPP from Kawasaki. I just would like to use the ski this summer and it not spend so much time being "worked on." I, too, am thinking this might be a loose wire. We have no codes on the dash and the dealer is wanting to change the ECU. I am wondering if anyone else has had a problem like this.

  4. #4
    halfassjack's Avatar
    Join Date
    May 2007
    Location
    Nicholasville, Ky.
    Posts
    549
    Need to single out what cylinder it is missing on then narrow it down to possible causes from there. Since you have two identical skis some parts swaping may be in order.

    David

  5. #5

    Join Date
    Mar 2008
    Location
    mississippi
    Posts
    510
    +1
    1
    Quote Originally Posted by Campo5474 View Post
    The Dealer has been pretty good as I am still in my factory warranty and I did buy the GTPP from Kawasaki. I just would like to use the ski this summer and it not spend so much time being "worked on." I, too, am thinking this might be a loose wire. We have no codes on the dash and the dealer is wanting to change the ECU. I am wondering if anyone else has had a problem like this.
    Well this wasn't a 250 but i did have a problem somewhat like this on a 15f. The dealer changed out the ecu and it fixed it somewhat, they ended up changing out the throttle body and it took care of it. The dealer said there was some sort of internal problem with it.. he didn't go into detail but my 15f was developing a dead miss when going thru a no wake zone. It never did give any codes. might check for a vac. leak too as i am thinking thats what was the deal with the throttle body on mine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 Ultra 250X No Power At All
    By Bonnell65 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 09-10-2013, 08:40 AM
  2. 2008 ultra 250x idle problem please help
    By benrock250x in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-29-2012, 10:32 PM
  3. 2008 ultra 250x boost problem
    By benrock250x in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-31-2012, 09:51 PM
  4. 2008 Ultra 250X
    By Ultra 250X in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-26-2007, 08:20 PM
  5. Ultra 250x Speedo Problems
    By UltraRider314 in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 07-28-2007, 07:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •