Results 1 to 7 of 7
  1. #1

    Join Date
    Mar 2010
    Location
    Orillia Ontario
    Posts
    8

    Virage won't start

    Hey just tried starting my 02 virage tx it started last week but tried on the water today and nothing. Plz forgive me me if anything seems stupid totally new to pwcs but tried to start it a few times and started once for about 3 seconds and died I think I might of flooded the engine I could smell gas so i'm Gunna pull the plugs is there anything else I can check or do thanks I also wondered about the battery but when sitting it's at 2 volts then trying to crank it was around ten I believe thanks alot
    Brady and if u could dumb down anything that would help alot


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Is this a carburetor or fuel injected engine?

    I suspect your battery is weak.
    The number one reason for no-spark on a Polaris PWC is a weak battery.

    You can check the battery voltage using a multi-meter (the built-in MFI digital display is not accurate enough for this).

    While cranking the engine
    , the battery voltage must stay above 10.6 volts.

    If the battery voltage drops below about 10.6 volts, you will not have spark while cranking.

    The simple answer, if you want to be sure, just go buy and install a new factory sealed AGM type battery. I recommend the Odyssey PC625.

    I am currently using a couple of Deka ETX16LM batteries in my own Polaris PWC, which are also of the AGM type.

    AGM type batteries are more expensive than the typical lead-acid battery, but they are an excellent battery for PWC use. And they won't leak, don't even have a vent nipple

  3. #3

    Join Date
    Mar 2010
    Location
    Orillia Ontario
    Posts
    8
    Still won't start put in the pc625 battery and it almost went but nothig, have spark from all plugs but gunna try to replace and see if that works anything else I can do thanks

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by alleyesonme0386 View Post
    Still won't start ... have spark from all plugs...

    ...anything else I can do thanks
    Quote Originally Posted by K447 View Post
    Is this a carburetor or fuel injected engine?...
    So you have strong spark on all three spark plugs, but no ignition when trying to start the engine - correct?

  5. #5

    Join Date
    Mar 2010
    Location
    Orillia Ontario
    Posts
    8
    Yes I have spark just gunna change the plugs in te next few mins and sorry don't no if it's carbd or furl injected how can I tell thanks

  6. #6

    Join Date
    Mar 2010
    Location
    Orillia Ontario
    Posts
    8
    Wow I feel smart poped the hood turned the gas on which was missed and she fired right up now I have an exta battery and plugs ah well thank you for the help this site is awsome

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by alleyesonme0386 View Post
    ...turned the gas on which was missed and she fired right up...this site is awesome
    To learn more about your PWC, click the link below, and spend some time reading.

    Lots of good info available around here

    If you have a fuel shut-off valve, then I would say your engine has carburetors, not fuel injection. On a carburetor engine, the spark plugs stick straight up out of the top of the engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 Virage won't start hot
    By Chester in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-11-2013, 12:19 PM
  2. Please Help! 2002 Polaris Virage won't start.
    By Parkeras in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 03-09-2013, 11:57 PM
  3. 01 Virage Won't Start, MFD = No Display!
    By ggrande in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-04-2012, 10:45 PM
  4. virage won't start after running for a while
    By culby-wan-kanobi in forum Polaris PWC Performance
    Replies: 27
    Last Post: 08-07-2008, 02:14 PM
  5. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •