Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260

    Catch can full after an hour ride

    Over the winter, I added a S3 SC and 42's among a few other things (non-motor related) and I finally got a chance to take it for a test ride. I had just de-winterized it and changed the oil, oil filter, and plugs about a week ago, and I had checked the catch can before I put it up for the season, and it was empty. After riding for about an hour today, it was full, and some of the oil/fuel mix was sprayed inside the hull. I wouldn't imagine this to be normal, so I am wondering if there is anything I should check, or just expect to empty it often. Thanks in advance!

    Justin


  2. #2

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by jdbretz View Post
    Over the winter, I added a S3 SC and 42's among a few other things (non-motor related) and I finally got a chance to take it for a test ride. I had just de-winterized it and changed the oil, oil filter, and plugs about a week ago, and I had checked the catch can before I put it up for the season, and it was empty. After riding for about an hour today, it was full, and some of the oil/fuel mix was sprayed inside the hull. I wouldn't imagine this to be normal, so I am wondering if there is anything I should check, or just expect to empty it often. Thanks in advance!

    Justin
    you sure it was empty? that seems a bit much like way to much. not sure... someone will chime in

  3. #3
    Cashito's Avatar
    Join Date
    Feb 2010
    Location
    Delray Beach
    Posts
    198
    +1
    4
    How low is the catch can?

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Did you overfill your oil?

  5. #5
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556
    that was my 1st question -- over full on the oil ='s blow by on the catch can

  6. #6
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    I could have over filled the oil a little. When I checked the level after I got home, it was right at the top of the dipstick, so maybe I over filled it a little.

  7. #7
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    The catch can is mounted using the Riva bracket that came with the kit (on the exhaust manifold)

  8. #8
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    Do you guys recommend I drain a little oil out to get it right under the full mark on the dipstick or just leave it?

  9. #9
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556
    all the past posts i have seen says to have the oil level at the half way point on the dip stick -- thats where i keep mine

  10. #10
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    Quote Originally Posted by homebrew View Post
    all the past posts i have seen says to have the oil level at the half way point on the dip stick -- thats where i keep mine
    Thanks, I'll have to drain a little out of both my skis, cause the other one is at the same level. Unfortunately it does not have a catch can, so all that oil/fuel is probably covering my SC and IC....too late now

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXT stalling at idle after an hour of use
    By govenatorx in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-03-2013, 06:41 PM
  2. will catch can be bad if i ride in salt water 70% of the time?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-24-2011, 12:06 AM
  3. Replies: 0
    Last Post: 07-21-2011, 10:05 AM
  4. Catch can full
    By JeffTurbo601 in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-08-2009, 01:51 PM
  5. SL900 - No Spark after an hour
    By rrated999 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-28-2008, 08:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •