Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303

    RC DI Wont turn over?

    I have a RXDI that was turning over and starting just fine. Took it down to the water today and went to start it and no go. When i put the lanyard on it turns on the fuel pump as normal, but when i hit the start button all it does it turn the fuel pump on. No click, or starter engaging. It started flashing Maintan with the red light. Any Ideas on what is going on? I just started it in the garage earlier this morning and it was just fine! What gives?


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    start with the simple things first. check the fuses and battery voltage.

  3. #3
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Burnt 5 A fuse on MPEM. Check wiring condition and replace fuse.
    Poor contact of battery terminal(s). Clean and tighten terminal(s).
    Poor battery ground cable connection. Clean and tighten.
    Weak battery. Recharge or replace battery.
    Poor contact of start/stop switch,
    safety lanyard switch or solenoid.
    Check connectors and clean contacts.
    Check and replace defective parts.
    Open circuit: start/stop switch or
    solenoid. Check and replace.
    Safety lanyard or MPEM.
    Refer to DIGITALLY ENCODED
    SECURITY SYSTEM or ENGINE
    MANAGEMENT.

    That's from the manual. After checking the fuses and battery (Check the connections too) I would go to the relay and see if you are getting a signal from the mpem. The switch tells the mpem to activate the solenoid for the starter.

  4. #4
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Thanks for that info RumRunner !

    The last fuse on the MPEM labled INJ was blown. Replaced it and she fired right up! Im used to working on these carb'd skis and they are not as complicated.

  5. #5
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    No prob, mibunker beat me to the check fuses and what he said about starting simple is always the way to start in my book. I was just trying to expand off what he started. Glad to hear it was something cheap and easy! FYI they do have manuals you can download here for free in the stickies. Now if summer would just get here

  6. #6
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Well I spoke too soon. The ski started back up, ran for 2 mins or so on the hose, beeped and shut off. The INJ fuse blew again... This same ski was running really ruff last time it was out. Im leaning toward bad injectors.

  7. #7
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    I have a 2001 RXDI and according to the schematic there is quite a few things that run off that INJ fuse. In mine there is a total of nine things. I would download a manual for your year and start checking resistance values on the items that run on it first. It sounds like it blows fairly quick so something is shorting out so hopefully doing resistance checks will help find the culprit. Good luck and hope you figure it out soon.

  8. #8
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Good info, Ron.

  9. #9
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Thanks Krunch, He may even want to stick a fuse back in it see if it starts, run it till the fuse blows and then get busy checking. You can also buy a auto-reset circuit breaker to take the place of the fuse of the same rating. It has that nasty little habit of fixing itself after cooling off. It could take some time to find whats popping that fuse and you could burn through a few fuses doing so. Just my .02 cents.

  10. #10
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Ok thanks again for the Info Ron. I will see if I can find and Download the manual later today. Here is what I think is going on. This ski came to me running extremely ruff. Max 3800RPM's in the water. I ran it around the lake for 20 minutes or so and it got better (6800rpms) but shortly after started missing again (5400)rpms when I finally put it back on the trailer. No Codes,no warning light, as far as the Computer knew everything was A ok. I cleaned the injectors with a can of carb/choke cleaner. let them sit over night. and even fired it up after that in the garage. I let the ski sit for 2 days. Went to take it out, and it started and within 2 mins it shut down on me flashing Maint. Brought it back to the house, noticed the INJ fuse blown, replaced it, started it on the hose, ran for 2 mins again sounding like it was idling funny then blew the INJ fuse again and shut down. Now, I replaced the fuse one last time, it started and idled on the hose for 2 or 3 mins, the customer wanted to come get it and see if it was any better. I had not tested it yet, but he really wanted to go riding this easter weekend. He said he got down to the lake, it started and idled, but then the wire hooking to the injector towards the front of the ski started smoking. He called me and i told him to shut it down, and remove the INJ fuse. Which he did and it stopped. After that he told me that the front Cyl which the injector started smoking on seemed to be making the plug extremely black the last couple months when it was running ok. Which means to me that being this ski is Oil injected that Injector has been going out for sometime (Lack of fuel causing that cyl to be burning mostly oil causing black plug), its just now got to the point where its no longer working and blowing fuses because its shorted out! I am getting the ski back Monday and want to figure this thing out! Im sure there is a resistance check I can do on the Injectors. Man now I know why all the post on the DI's have been stay away! LOL

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT engine wont turn over
    By bairstow in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-18-2008, 12:36 AM
  2. 1100 stx di wont go over 40mph
    By cameron da river rat in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 05-29-2008, 10:10 AM
  3. Wont turn over
    By PHISH in forum Yamaha How To & FAQs
    Replies: 6
    Last Post: 04-13-2008, 11:21 AM
  4. motor wont turn over with the spark plugs installed
    By gianni57 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 07-30-2007, 11:35 PM
  5. Virage TX wont turn over(2001)
    By pirate33 in forum Polaris How To & FAQs
    Replies: 38
    Last Post: 11-24-2006, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •