Page 1 of 14 1 2 3 11 ... LastLast
Results 1 to 10 of 137
  1. #1
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253

    HighPSI runs 90.8 today on RXP-X

    Just spoke to Cal Hartline (highpsi) and he is just leaving the water. His 2008 x-ski has just gone 89.0 with almost a full tank, sitting on the seat !!! He had previously gone 87.1, Cal went this afternoon and let Duke work a little magic on the prop. First pass on the lake, 89.0 wow, congrats to Cal, Duke, tantrum, jp1300r for all their hard work. This has to be the fastest x ski in the world to my knowledge. Cal still runs opas, stock exhaust outlet, stock intercooler etc. This was with 17lbs at 8700rpm. Cal is about to throw on the Riva plate on Monday. If the plate gives him two or three mph, it should go 91 or better......
    Last edited by vspec1; 04-05-2010 at 03:49 PM. Reason: Ski went faster


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215

  3. #3
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    thats.....SMOKIN!

  4. #4
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034

  5. #5
    HighPSI's Avatar
    Join Date
    Jun 2008
    Location
    Melbourne, FL
    Posts
    410
    Thanks guys!!! I really didn't plan on running the ski hard today. I just wanted to check some data. On a quick blast checking the pump pressure it went 87.8 I realized how easy that was so decided to make a hard pass and managed an 89.0. Duke's repitch today brought the rpm's down to 8700 which is great because I now have room to turn the boost up
    Tantrum has spent more hours working on my ski than I have and will probably be the jockey if it ever hits 90mph!
    I can't wait to take it on the St John's ride tomorrow

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by HighPSI View Post
    Thanks guys!!! I really didn't plan on running the ski hard today. I just wanted to check some data. On a quick blast checking the pump pressure it went 87.8 I realized how easy that was so decided to make a hard pass and managed an 89.0. Duke's repitch today brought the rpm's down to 8700 which is great because I now have room to turn the boost up
    Tantrum has spent more hours working on my ski than I have and will probably be the jockey if it ever hits 90mph!
    I can't wait to take it on the St John's ride tomorrow
    That x is flying, nice job.
    I couldn't remember, but is it o/l or c/loop?

  7. #7
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    what happens when you are going 90 and the bottom delaminates, or did they fix that problem.

  8. #8
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by xBigDaddyx117 View Post
    what happens when you are going 90 and the bottom delaminates, or did they fix that problem.
    its very rare on the new skis, more of a problem on 04-05's.

  9. #9
    FrankieV123's Avatar
    Join Date
    Aug 2008
    Location
    Florida -JERSEY
    Posts
    260
    +1
    1
    Congrats... You guys gotta get a video up when ya hit 90...awesome results guys

  10. #10
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    yeah point the camera strait forward and do a flyby without moveing the camera, that will give us a good perseption, rrrrrrrrRRRMMmmm.....

Page 1 of 14 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 06-09-2013, 09:17 PM
  2. what do i need to run a x charger on an 07 rxp stock ecu?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-27-2011, 09:09 AM
  3. can i run a 06 riva on 04 rxp
    By stevorxp007 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-22-2010, 11:37 PM
  4. Made my first run on RXP... bad news
    By konabiker47 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-08-2007, 11:44 PM
  5. ECU up and running on RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-16-2006, 12:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •