Results 1 to 2 of 2
  1. #1

    Join Date
    May 2005
    Location
    St. Louis MO
    Posts
    441

    Set Button came off and loosing take off speed!

    I was at the lake yesterday and my set button came off when I was going 60+, so I went to the dealer and the ordered the part and said it would be in 3 days or so! Covered under my warranty!

    I think I am losing some take off speed! It might be my wear ring! I have 35 hrs on my rxp! I think I will have Frank help me with this one later!

    Also I normally run 7800 all day in 95-100 degree TX heat! I decided to take off my seat cover and make a run and it ran 7900 with out the seat cover!

    I am still running stock, except for the exhaust pipe which I put in!


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,341
    +1
    2,494
    Change your wear ring!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 XL1200 LTD slow to plane and then takes off
    By Sparkrider84 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-12-2015, 11:04 AM
  2. Replies: 18
    Last Post: 05-27-2012, 04:55 PM
  3. RXPX Nose cone O Ring Came Off..still intact what to do?
    By FrankieV123 in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-17-2009, 11:41 AM
  4. Just came off lake. cant believe speed!
    By piper250 in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-07-2007, 03:25 PM
  5. Mirrors came off
    By RapidFire Inc. in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-23-2007, 12:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •