Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83

    I expected Alot with those mods !!!

    ok my mods are...Flame arrestor, D-plte, Intake grat, rider plate, 14/20 impeller and Riva EFI controller. i expected to hit somewhere near 65 but i get stuck in 62.9 .... my EFI setting is 6-7-2-6

    any help in improving my ski...??!!specially in EFI setting i know im running low in the RPM mode but when i get it 9 or 8 it keeps on bogging and i loose bottem end...


  2. #2
    GPHOTROD's Avatar
    Join Date
    Apr 2006
    Location
    Dearborn Heights, Mich
    Posts
    65
    What year ski?

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

    Question

    What are your RPMs ?

    Do you have an aftermarket digital tach ?

    Also, do ao compression check.

    Do you have aftermarket or milled heads? or stock compression ?

    What year is this ski ?

    2003-2004 powervalve
    or
    2005-2006 non-powervalve

  4. #4

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    Quote Originally Posted by RX951
    What are your RPMs ?

    Do you have an aftermarket digital tach ?

    Also, do ao compression check.

    Do you have aftermarket or milled heads? or stock compression ?

    What year is this ski ?

    2003-2004 powervalve
    or
    2005-2006 non-powervalve
    2006 gp1300
    no tach so no rpm....

    i did a compression test and im having 145 psi....

  5. #5
    I have basicly the same setup and am running a lot different on my efi. I know everyone has different settings but with
    d-plate
    14/20 dynafly
    ride plate
    ppk
    and intake grate
    I am running 2.5,3,1,7

    Its still slow out of the hole but it will run 69-70 all day. still have some tuning to do on it. But with 6,6,2,9 it would bog and spit and sputter.

    Def get you a tach of some sort. They are alot of help on tuning.

  6. #6
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    EFI is set to rich! My friends with a similiar setup is running 3.5-4-1.5-7 and he is running 70's
    Last edited by r33pwrd; 09-13-2006 at 05:07 PM.

  7. #7

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    Quote Originally Posted by r33pwrd
    EFI is set to rich! My friends with a similiar setup is running 3.5-4-1.5-7 and he is running 70's

    ALSO GET A RACE FILTER! It will help you a lot!
    If i ran my EFI with those number wont i be lean ??

    anyways i will try it tomorrow and i will c what difference i will have...

    and anyone reading...any suggestions ??

  8. #8
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585
    your compression is 145 with a stock head?

  9. #9
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    your current efi settings are higher than my ski (see my signature for mods) there are other factors but you should be fine to lean her out a bit! You need to get a tach!

  10. #10
    GPHOTROD's Avatar
    Join Date
    Apr 2006
    Location
    Dearborn Heights, Mich
    Posts
    65
    r33pwrd is right efi is to rich, with stock reeds, no porting and stock head, high speed or the red dial should most likely be on 1 and should come on between 5500-6000. You really need a tach because the rpm dials aren't right most of the time, my red comes on at 5600 with the rpm dial set on 7 1/2.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can I turn a 15/22 with those mods??
    By pass1 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-15-2012, 11:59 AM
  2. Special Kits for thoses with light mods!!
    By ArmyRXP in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-28-2006, 12:19 PM
  3. Riva Stage II with Waterbox Mod
    By johnD in forum 4-Tec Performance
    Replies: 22
    Last Post: 02-23-2006, 11:16 PM
  4. what gains with these mods
    By rxpblast in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-14-2005, 10:16 AM
  5. ? for anyone with a modded rxp
    By seadoo02xp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-27-2005, 05:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •