Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    Join Date
    Apr 2010
    Location
    Atlanta
    Posts
    49

    Should I expect more???

    I bought a 2007 RXT with 30 hours on it. It has the replacement supercharger with the steel washers. I took it out in November and ran [email protected] RPM according to GPS. This winter I put on a full stage 1 kit and tried it out today using the same GPS and with the same level of fuel. The water was 60 degrees and the air temp was 83 degrees. This time I see [email protected] RPM. Not much of a difference. 0.7 isn't what I was expecting. The hole shot is a ton better as is the handling. I really want to get to a true 70-75 mph on this ski. I was hoping the stage 1 would have done the trick. I guess not. The wear ring is also new so I am doubting cavitation especially with that hole shot. Any advice would be GREATLY appreciated.


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    your missing 200rpm.. what mods have you done

  3. #3

    Join Date
    Apr 2010
    Location
    Atlanta
    Posts
    49
    RIVA Performance Power Filter Kit
    RIVA Top-Loader Intake Grate
    Solas R-Series Concord Impeller SRX-CD-14/17R
    RIVA Pump Wedge
    RIVA O.P.A.S. Competition Kit

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I agree with Dockside you are missing some rpms. Rpms stock should have been around 8100. Thats what the one I just sold would do stock. With a Riva stg1 it should be around the same rpms and about 70 mph.

  5. #5

    Join Date
    Apr 2010
    Location
    Atlanta
    Posts
    49
    Is there anything that I can check for to find why I am loosing the RPMs?

  6. #6
    TEX-X's Avatar
    Join Date
    Jul 2008
    Location
    Pecos, TX
    Posts
    210
    check into the wear ring... that's a possibility.... maybe someone else will chime in.... any other problems with the ski? did you put the new supercharger in? who rebuilt it?

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by TEX-X View Post
    check into the wear ring... that's a possibility.... maybe someone else will chime in.... any other problems with the ski? did you put the new supercharger in? who rebuilt it?
    +1
    I would look at the sc, also look for a boost leak.

  8. #8

    Join Date
    Apr 2010
    Location
    Atlanta
    Posts
    49
    The wear ring is new, I installed it when I put in the new impeller.
    A seadoo dealer installed a new SC last summer to replace the one with the ceramic washers, done under warranty.

    How do I check for a boost leak?

  9. #9
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    I agree that you are missing 200 rpms right Now.
    Check your oil level, spark plugs, etc etc before
    you start changing things.
    Just a little TLC maint goes a long way.

    IF you want 70++ you will need to do a full
    stage 3 mod to your ski
    70 is still a long ways away for you. Will need to mod a lot more.
    75 is territory that's pretty rare on a couch w/o a lot
    of money, time, experience.

    Check the obvious things first. Your environment plays
    a BIG factor on how your ski runs.
    You cant always compare your mods to others for an exact
    match.
    Also there is a diff from ski to ski. These are mass produced,
    so there are a lot of tolerances that can stack up more
    from 1 boat to another
    Last edited by Foggy; 04-03-2010 at 11:22 AM. Reason: MISSPELL

  10. #10

    Join Date
    Apr 2010
    Location
    Atlanta
    Posts
    49
    I took the ski out again yesterday when I realized that I had put in fuel stabilizer when I winterized the ski. I ran out all of the gas and will try putting in some fresh 93 octane fuel. Hopefully it was just the fuel stabilizer causing the problem.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What should I expect...?
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-28-2007, 05:37 PM
  2. Just Bought the Riva Intake Grate, What Should I Expect?
    By Haislip in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-31-2006, 04:23 PM
  3. what should I expect with a Stage 1 RXP when adding RR SC
    By rxp_boy in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-20-2006, 07:37 AM
  4. How much performance loss should I expect?
    By Lurker in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 05-08-2006, 01:48 AM
  5. What should I expect to pay?
    By Denali44 in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-28-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •