Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2010
    Location
    San Diego, C
    Posts
    3

    '98 SLTH 700 won't rev past 3400 rpm

    Hi guys,
    I'm a motorcycle mechanic trying to help my neighbor with his SLTH. He just bought it last week, and when he put it in the water, he found that it would only take about 1/3 throttle before the motor started missing/loading up. Also, the MFD had a flashing red LED, but no display of overheat. The LED does not respond to manual reset.
    He has drained the fuel tank, cleaned the fuel filter and replaced the plugs. No change.
    So now I have gotten involved. I started with checking the fuel pump and cleaning the carbs. Fuel pump is OK. There was a substantial amount of dirt on the fuel inlet valve screens, but they were still passing fuel. I put a straightedge across the carb body and measured the clearance to the inlet valve lever. It seems a little more than the 1.5mm specification, but I did not change it because it would have resulted in a richer fuel condition, and it seems too rich already. I put the carbs back on only to find nothing had changed.
    Next I removed and inspected the reeds and reed block. They look fine with no measurable gaps at the reed/reed body. Reassemble and test....Same condition.
    The flashing LED was bothering me, thinking an overheat condition might have triggered the rev limiter. I removed and visually inspected the sensor. No corrosion or loose connection. Then I temporarily disconnected the sensor wire (tan) from the electrical box. When I stated it up, the LED was still flashing, and again, there was no difference in the way the motor ran. It's still crapping out around 34-3500 rpm and backfiring through the carb throttle plates.
    At this point I suspect it could be an ignition problem with timing or spark advance, but have not yet checked either of those.
    If anyone has had a similar problem, I would appreciate any information you could give me. Thank you.
    BlueDogLeader.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Welcome to the Hulk

    Quote Originally Posted by BlueDogLeader
    ...backfiring through the carb throttle plates...
    Since you have checked the reeds, my initial suspicion is that the engine still has the original ignition system, which are known to fail over time.

    Check the part number on the CDI module inside the electrical box. If it is not the updated part number, then the Ignition System Update Kit may be the answer.

    There is no test for the actual CDI module, other than swapping in another known good CDI. The magneto stator coils and Hall Effect sensor can be tested with a multi-meter.

    If the magneto stator tests good, then the CDI may have failed => Install the Update Kit
    If the stator tests bad => Install the Update Kit

    Short answer, install the Ignition Update Kit. Cost is around $300

    BTW, check the reeds again. The backfiring might have damaged them

    Click below for more info

    Polaris Domestic (red) engine

    Once you install the ignition update kit, you must use 2000 and later Service Manual specs when diagnosing the ignition system and stator coils.
    How do I tell whether I have an updated or original type domestic ignition?
    What does a non-updated two cylinder Ignition coil look like?
    How do I test old and new domestic red engine CDI, Magneto and Ignition coils?

    Polaris domestic engine Ignition System Update Kits


    All 1996-1999 two and three cylinder carburetor engines [excludes all 1999 1200(1165cc) engines]
    Kit part numbers 2873091, 2873022, 2873355, 2873356
    2873022 1996-1997 Hurricane and twin carburetor 1998-1999

  3. #3

    Join Date
    Apr 2010
    Location
    San Diego, C
    Posts
    3
    K447,
    Thanks for the quick reply and information. I'm going to use the links you provided to determine what ignition module is installed.
    Any thoughts on the flashing LED?
    BlueDogLeader.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by BlueDogLeader View Post
    ...Any thoughts on the flashing LED?...
    What text message is showing on the display when the LED is flashing?
    Low OIL
    Low Fuel
    HOT

    You might need to press the Mode button to see the message

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 polaris slth won't Rev past 4000 rpm
    By Jbrann in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-31-2016, 10:20 AM
  2. 1999 polaris slth won't Rev past 4000 rpm
    By Jbrann in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 07-21-2016, 10:54 AM
  3. 1999 SLTH 700 won't rev past 5600
    By litebrite2001 in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 03-27-2012, 10:45 PM
  4. 2002 Polaris Genesis I won't rev past 4000 rpm
    By 440/650 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-12-2011, 02:51 PM
  5. WaveRaider won't rev past 3000 RPM ?
    By Jolly Roger in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-20-2008, 02:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •