Results 1 to 2 of 2
  1. #1
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672

    Ultra 250 No Start, need help

    2007 Ultra 250.
    No power to instrument cluster. No start.
    Power at battery, etc.

    Can "jump" terminals at relay by battery
    to get starter to crank just fine.

    Think it's maybe the starter relay module, but
    can't seem to find the right part number.

    Any help on this issue is appreciated.


  2. #2
    jet ski o'clock's Avatar
    Join Date
    Jan 2009
    Location
    bayville n.j.
    Posts
    161
    +1
    6
    is the 1 small wite connected to the battery ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 gp1200 no start need help
    By trevor in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-18-2011, 10:52 PM
  2. ultra 150 no start. need help ASAP!!
    By vettez062002 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-11-2010, 05:56 PM
  3. won't start, no click need help ASAP
    By tweeder in forum Polaris Open Discussion
    Replies: 17
    Last Post: 07-30-2010, 10:39 PM
  4. 2005 GP1300R wont start (no spark) - Need help
    By arielsdv in forum Yamaha PWC Performance (2-stroke)
    Replies: 43
    Last Post: 04-25-2009, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •