Results 1 to 7 of 7
  1. #1
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5

    How muck to pitch??

    Comming back from my 1st ride of the season.
    Air temp 80', water 44'. no speed recorded as I don't have a gps.

    Over the winter I have done the following mods to my gtx 215...
    x charger, 42# injectors, 15/20r prop, bypassed resonnator.
    At holeshot, I'm all over the limiter and only at 3/4 throttle, but at 30 mph and going WOT it jumps at 7700 and climbs up.
    So I need to pitch my prop but what do I start with... 1 or 2 mm??

    Thanks!!


  2. #2
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Sounds like you are cavitating on holeshot.
    What are your rpm's at WOT at top speed ????

  3. #3
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    Hi, got a seal if ya need it for your cav problem, if thats what it is.

  4. #4
    start with 1mm....then a gps.

  5. #5
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5
    Quote Originally Posted by Foggy View Post
    Sounds like you are cavitating on holeshot.
    What are your rpm's at WOT at top speed ????
    That is what I taught as well. When I baught my prop (used but untouched) it had a blue nose come on it, I tried to remove it to put my rubber stock one on but it's seized solid. Could it be '' Part '' of my problem?? or if just pitching it will solve the problem?? Clearance on wear ring is perfect between 0.009'' and 0.012''.
    Didn't had a chance to try it at top speed but looks like I lost some (going with speedo) compared to last year (stock). 60 mph at 7700-7800rpm

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by pass1 View Post
    That is what I taught as well. When I baught my prop (used but untouched) it had a blue nose come on it, I tried to remove it to put my rubber stock one on but it's seized solid. Could it be '' Part '' of my problem?? or if just pitching it will solve the problem?? Clearance on wear ring is perfect between 0.009'' and 0.012''.
    Didn't had a chance to try it at top speed but looks like I lost some (going with speedo) compared to last year (stock). 60 mph at 7700-7800rpm

    Don't run the OEM nose cone. Leave the one thats on it on.

  7. #7
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5
    Well... Took the pump appart to start pitching and maybee found some of my problem, found out the hose for the opas to be unpluged... was wondering why my ski felt more agressive on sharp turns, think I know why since the paddle stayed down acting like a rudder. Probably that caused me to loose a bit of top speed as well. Will se with new pitch maybee this afternoon.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can someone post a video on how to pitch a impeller.
    By travis ingram in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-12-2015, 11:28 AM
  2. how to pitch a prop????
    By syk1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-08-2008, 02:16 PM
  3. How not to fix a flooded engine.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-22-2006, 04:41 PM
  4. Replies: 5
    Last Post: 07-12-2005, 07:42 PM
  5. Rotax Racing - How hard to install...
    By Jarrett in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-08-2005, 08:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •