Results 1 to 8 of 8
  1. #1
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270

    785 water issues

    hey i bought a flush kit so i could run the engine and do various ops checks. the prob is that when the hose is hooked up water comes out of the area where the head pipe meets the engine and nothing comes out the pissers. im gonna take it out on the water and see what happens but just for reference what temp is a bad range to be in?


  2. #2

    Join Date
    Jul 2008
    Location
    England.Great Britain . UK
    Posts
    276
    i would nt take on water, until sorted whats wrong !!!!!!

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by killcraft View Post
    hey i bought a flush kit so i could run the engine and do various ops checks. the prob is that when the hose is hooked up water comes out of the area where the head pipe meets the engine and nothing comes out the pissers. im gonna take it out on the water and see what happens but just for reference what temp is a bad range to be in?

    it really won't come out of the pissers till the whole system is full of water and on a hose that will take awhile because you have no back pressure on the system to fill the pipes.
    Take it to the water and start it on the trailer and water should come out of the pissers in about 30 seconds or so .
    Then just let idle on the trailer and check for any leaks

  4. #4
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    ok i rode it today man she can move!!!!
    any way looks like water is leaking from where the head pipes meet the engine figure ill see if i cant get a few more turns on the screws. that should solve the prob. and as far as water coming outta the pissers bob you are right after about 30 sec in the water it came out of all three

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by killcraft View Post
    ok i rode it today man she can move!!!!
    any way looks like water is leaking from where the head pipes meet the engine figure ill see if i cant get a few more turns on the screws. that should solve the prob. and as far as water coming outta the pissers bob you are right after about 30 sec in the water it came out of all three

    Cool
    yeah get that water leak fixed ,there pretty cool rides huh ???
    make sure you check your plugs to make sure your not running lean

  6. #6
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    ok pulled the plugs alright im not the greatest at this reading plugs business for two strokes to me they look like they are rich but ill let you guys be the judge if i do need to adjust the carb someone is gonna have to walk me through that cause quite frankly its scares the crap outta me!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00910.JPG 
Views:	42 
Size:	2.77 MB 
ID:	181855   Click image for larger version. 

Name:	DSC00911.JPG 
Views:	48 
Size:	2.73 MB 
ID:	181856  

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Plug reading is only accurate after a WOT pass.

    If you idle back to the dock, you're actually seeing the idle circuit.

    Piston wash is more of an accurate reading of fuel supply.

    But if you do a plug chop, it can be a decent visual.

    What you need to do is run WOT and pull the lanyard. Then you remove the spark plugs and inspect them for the color.

  8. #8
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,141
    +1
    1,051
    What he said ^^^^^^

    And set your camera to "closeup mode".... usually indicated by a flower icon. That way we can see the detail.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pro 785 Water Routing
    By beerdart in forum Polaris PWC Performance
    Replies: 53
    Last Post: 09-08-2013, 09:23 PM
  2. 1998 Pro 785 water routing
    By hyoctane23 in forum Polaris Open Discussion
    Replies: 29
    Last Post: 04-17-2009, 04:13 PM
  3. Pro 785 water routing
    By racer447 in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-17-2008, 09:23 AM
  4. Pro 785 Performance Issue
    By racer114 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-04-2007, 10:13 PM
  5. RXT/GTX Front storage compartment water issue!
    By majundecid in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-22-2006, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •