Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211

    Oil leak from PTO please opinions

    can anyone tell me FOR SURE if it is normal oil coming out of the pto now that the driveshaft is out ?
    I have read each and every single thread but no-one seems to have analyzed it so deep. In my opinion if oil is coming out all the time from there, then the bearing will fed up with engine oil and then it will start leaking again. so is there any chance that somehting else is wrong or is it normal oil keep on coming out of there ? ESPECIALY when i tilt the trailer oil is coming out like crazy. (and in that matter, do you guys leave the trailer tilted after washing it ? and for how long ?)

    I am trying to gather all the items I will need for my oil leak problem, so that I can have them in one order since shipping costs will kill me for having the items shipped in Greece, where I leave.

    SO i would apreciate the most entousiasm about my thread. thx in advance

    thank you so much.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1342.JPG 
Views:	229 
Size:	310.4 KB 
ID:	181996  


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Normal.

  3. #3
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    can you be a little more analytical ?

    also do you leave the ski on lift to drain water out ?does this make things worse ?

  4. #4
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    the pic as you show is normal and there is a lip seal (no spring type) in the end of the spline to keep to much oil going down the shaft and 2 orings that seal the bearing against the shaft itself.
    When the shaft has been out often the bearing slips out of the rubber boot or the orings get damaged causing a leak.
    When I take shafts out oil wont always come out as these engines move oil around the motor so there is'nt always the same amount in the pto housing.
    If everything is in place and it leaks the bearing is faulty as its internally sealed itself.
    When installed it need to be pulled back along the shaft as far as it will go it can sit to far forward and the orings dont seal on the shaft.

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by jasonze View Post
    the pic as you show is normal and there is a lip seal (no spring type) in the end of the spline to keep to much oil going down the shaft and 2 orings that seal the bearing against the shaft itself.
    When the shaft has been out often the bearing slips out of the rubber boot or the orings get damaged causing a leak.
    When I take shafts out oil wont always come out as these engines move oil around the motor so there is'nt always the same amount in the pto housing.
    If everything is in place and it leaks the bearing is faulty as its internally sealed itself.
    When installed it need to be pulled back along the shaft as far as it will go it can sit to far forward and the orings dont seal on the shaft.
    Thanks.

  6. #6
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    Quote Originally Posted by jasonze View Post
    the pic as you show is normal and there is a lip seal (no spring type) in the end of the spline to keep to much oil going down the shaft and 2 orings that seal the bearing against the shaft itself.
    When the shaft has been out often the bearing slips out of the rubber boot or the orings get damaged causing a leak.
    When I take shafts out oil wont always come out as these engines move oil around the motor so there is'nt always the same amount in the pto housing.
    If everything is in place and it leaks the bearing is faulty as its internally sealed itself.
    When installed it need to be pulled back along the shaft as far as it will go it can sit to far forward and the orings dont seal on the shaft.
    in my case the oil was coming from inside the bearing itself. i post a new picture and you can see the oil pouring out. could it be that the previous owner had removed the shaft and as he pulled it out the bearing was damaged and pulled outwards creating a gap and hence oil coming out of there?

    also can you explain to me again regarding the reinstalment of the shaft ? does it have a special procedure ?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1127.JPG 
Views:	184 
Size:	117.2 KB 
ID:	182005  

  7. #7
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    bump, just found out i have a similar problem. but the oil on my 04 rxp is dripping down the pto not the bearing. does it mean i need to replace the boot with the bearing?

  8. #8
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    the boot unfortunately comes as one part with the bearing. if you are leaking from the boot then you need to replace this part. be very carefull when locating your leak. I had to take many pictures wth my camera in ord to see exactly where i wasleaking from. it might not be the boot.if you are leaking from down under the pto it might be the gasket that connects the pto with the engine. this is very rare though, and best chances is that your boot is torn out for some reason....best of luck

  9. #9
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    didnt eplain my self to well sorry...i dont mean eaxctly under the pto its rigght under the boots closest to the pto. after removing the sc i saw that i was missing one hose clamp so hopefully that is the problem.

  10. #10
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    that is great. if it is not torn out just put a new clamp in there and you should be fine

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT Oil Leaking from Somewhere - please help?!
    By nceduc8r in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-17-2013, 05:37 AM
  2. Oil leak from engine driveshaft-pto HELP>..
    By Rt-HemiBoY in forum 4-Tec Performance
    Replies: 19
    Last Post: 10-14-2012, 10:39 AM
  3. HELP! Oil leaking from where midshaft connects to engine.
    By o uncola o in forum Conversion PWC Performance Skis
    Replies: 8
    Last Post: 08-10-2010, 12:07 PM
  4. 95 montego with oil leaking from vent
    By calex42 in forum Tigershark
    Replies: 1
    Last Post: 10-05-2009, 06:39 PM
  5. Oil Leak from blow off valve???
    By fasted1500 in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-26-2008, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •