Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 64
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    2003 Virage I and 2002 Virage TXI with Problems

    hello,
    I just purchased two virage ski's with issues.
    The 2003 Virage I
    It that sat outside all winter. Owner said it ran fine when stored last Spring. ( I am not so sure) It fired up for me once. The fuel tank was empty while it was winterized so I added 4 gallons of premium fuel. Then it wouldn't start, but it stuttered every once and a while while cranking. Fuel cap may have been loose (water in Fuel?) . I fired starting fluid into the arrestor a couple of times. Now the ski will start without starting fluid and run for 5 seconds and then shut off. It can be restarted and run another 5 seconds....over and over etc. If I try to touch the throttle even the slightest bit it immediately dies. While it idles the 5 sec on the trailer it is at 1000 rpm. I pressed the Schrader valve while turning over and fuel shot out in a stream about 10 inches long. I have not pulled the plugs to check compression.

    The 2002 Virage TXI
    This ski also sat outside all winter. The owner stated that the engine was completely rebuilt and overbored. He was out on the lake and it died while out on the lake. He told me that the dealer stated that the fuel pump was bad. It turns over fine, but no fuel pressure at the Schrader valve during cranking. Is there a fuse or breaker for the fuel pump? If so where is it located? Is there a good place to download a service manual? I tried some starter fluid into the air filter assembly and it did not fire.
    Please help....


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Welcome Dale

    There is a fix for the fuel pump, see below

    An engine that won't fire with starting fluid (ether, I presume)

    Check compression on both engines.

    Buy a fuel pressure gauge (about $20 at Harbor Freight).

    Also check for spark on the Virage i.

    Polaris Ficht Fuel Injected Engines

    Check for Service codes in each EMM.

    Note that even though they look the same, you cannot swap the EMM between two and three cylinder Ficht engines.

    For water in the fuel, remove the filler hose at the top of the tank, and look inside, or dip a siphon tube down and see if there is water on the bottom of the tank (water will sink to the lowest place in the tank). Be careful - no sparks. Use an LED light.

  3. #3
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Welcome to Green Hulk !

    Are these the 3 Virage's that recently sold on E-bay ? In Ohio ?

    Always start with the battery,it needs to be very strong,like 10.6 volts while cranking.

  4. #4

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Thanks for the welcomes...
    Yes, I got them off Ebay.
    It was a 2002 Virage TXI (60 Hours) a 2003 Virage I (90 Hours) and a double trailer.
    The 2002 Virage has some pretty bad hull damage to the side, but I think the engine is good.
    If I can get the injected ones running I think that I did pretty well.
    I am going to try and look at the pumps tomorrow. I borrowed a pressure gauge and tried to check the pressure of the Virage I today. It didn't start, but I had about 8 psi at first. As I cranked it over several times it slowly climbed each session of turning the engine over in 6 sec intervals. It got to about 20 psi after several cranking sessions. Is this normal or should I have 20 PSI or better right away?
    Last edited by dalepatter; 06-23-2010 at 07:23 AM.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Quote Originally Posted by dalepatter View Post
    ...I borrowed a pressure gauge and tried to check the pressure of the Virage I today.

    It didn't start, but I had about 8 psi at first. As I cranked it over several times it slowly climbed each session of turning the engine over in 6 sec intervals. It got to about 20 psi after several cranking sessions.

    Is this normal or should I have 20 PSI or better right away?
    Was the battery strong?

    You MUST use a healthy battery with these fuel injected engines. The fuel pressure should have jumped to over 20PSI right away, as the fuel pump is electric.

    Battery voltage while cranking should be well over 10.6 volts.

    Polaris Ficht Fuel Injected Engines

  6. #6

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    My battery dropped to 10.4 volts sometimes. I kept charging it back up.
    I pulled the fuel tank today and found two very distinct layers in the tank. I think there is a bunch of water in the bottom of the tank. After cleaning the tank is there anything to do other than draining the lines as much as I can. I have attached a picture of some of the fuel I removed, it looks pretty bad. There is a dark layer and a lighter layer.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	two layered Fuel.jpg 
Views:	107 
Size:	186.0 KB 
ID:	182273  

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Quote Originally Posted by dalepatter View Post
    ...found two very distinct layers in the tank.

    I think there is a bunch of water in the bottom of the tank.

    After cleaning the tank is there anything to do other than draining the lines as much as I can.

    I have attached a picture of some of the fuel I removed, it looks pretty bad. There is a dark layer and a lighter layer.
    I would blow some compressed air through the fuel lines, to clear out the injectors.

    I suppose you could remove the injectors from the engine
    That will allow the tips to leak/drain fuel from inside the injectors.

    Just don't highly pressurize the fuel injectors when they are not bolted into the heads. The tips are just a friction/snap fit into the injectors, and you don't want them to go flying.

  8. #8

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Thanks for all the help with the Virage I.
    I cleaned the tank and put new fuel in. There was at least a gallon of water in the tank
    The good news is that after the clean-out it started right up. It idles and Revs fine. The real test will be in the water
    Now I have to figure out why the TXI has no fuel pressure.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Quote Originally Posted by dalepatter View Post
    ...Now I have to figure out why the TXI has no fuel pressure.
    Check the fuel pressure regulator;

    How to repair a Ficht fuel pump - pressure regulator has fallen inside
    Symptoms include very low fuel pressure, rough running above idle, engine surging, and lack of power above idle.
    Red light and 'Check Engine' message typically appear on the display.

  10. #10

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    I powered the pump with the brown wire to the pump. I can hear fuel flowing in the lines and dumping into the tank. When I clamp between the valve and the tank, fuel stops dumping in the tank but I still read zero psi. Whats next?
    Thanks for the assisitance.

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 07-21-2016, 10:44 AM
  2. 2002 Virage TXi with low fuel pressure
    By woodsrider40 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-20-2016, 06:48 PM
  3. FS 2002 Virage TXI and 2003 Virage I with Double Trailer
    By dalepatter in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-25-2010, 05:01 PM
  4. 2003 Virage Txi DI low hour motor blow
    By ras928 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-03-2010, 10:12 PM
  5. Virage txi with a turbo!
    By viragetxi2002 in forum Polaris PWC Performance
    Replies: 8
    Last Post: 07-15-2007, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •