Results 1 to 5 of 5
  1. #1

    04 f12x throwing 2-5 code

    First I drained all the old fuel and replaced with 93 octane. Still threw the knock sensor code.

    I then changed the knock sensor and it Still threw the knock sensor code.

    The waste gate opens and closes at 8psi even when the turbo gets hot.

    Any ideas what to try next???


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by prbucci View Post
    First I drained all the old fuel and replaced with 93 octane. Still threw the knock sensor code.

    I then changed the knock sensor and it Still threw the knock sensor code.

    The waste gate opens and closes at 8psi even when the turbo gets hot.

    Any ideas what to try next???




    Probably need a ECU but Id check to make sure there is nothing wrong with the wire from the sensor to the ecu.....you can do a ohm check on the wire

  3. #3
    Checked lead wire and it was good to the ecu and I replaced the plugs and it still threw the code.

    How often do these knock sensors go bad?

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by prbucci View Post
    Checked lead wire and it was good to the ecu and I replaced the plugs and it still threw the code.

    How often do these knock sensors go bad?





    The ECU is probably bad if you replaced the knock sensor and the wire ohms out good....you need to replace the ECU with a known good one

  5. #5
    german06's Avatar
    Join Date
    Dec 2009
    Location
    Fortlauderdale
    Posts
    69
    Quote Originally Posted by prbucci View Post
    First I drained all the old fuel and replaced with 93 octane. Still threw the knock sensor code.

    I then changed the knock sensor and it Still threw the knock sensor code.

    The waste gate opens and closes at 8psi even when the turbo gets hot.

    Any ideas what to try next???
    THat happen to me, check if the ecm connection have corrotion, or do the test of the knock sensor it is in the service manual.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 F12X jet pump
    By Dirtnut in forum Honda How To & FAQs
    Replies: 8
    Last Post: 02-24-2010, 11:06 PM
  2. 04 f12x issue
    By bigdeez in forum Honda Performance
    Replies: 5
    Last Post: 07-29-2009, 01:37 PM
  3. 04 F12x
    By rexzazo in forum Honda Skis
    Replies: 0
    Last Post: 10-26-2008, 07:43 PM
  4. 04 f12x max speed??
    By rexzazo in forum Honda Open Discussion
    Replies: 10
    Last Post: 10-12-2008, 09:54 PM
  5. OIl for 04 f12x
    By rexzazo in forum Honda Open Discussion
    Replies: 3
    Last Post: 10-09-2008, 12:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •