Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308

    Speedo Sending Unit

    The little wheel/cog piece on the right bottom rear of the ski. This is for a 2006 RXT. The wheel barely turns, feels as if bearings are gone - I've checked, but don't see anything jammed up in there. I know it's not 100% accurate, but I'd like my speedo to work correctly.

    What am I looking at labor-wise to replace it? Looks like 3 screws to be removed from the outside... maybe just a new part, reconnect some wires and silicone and re-attach?

    - please.


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by 83Gator View Post
    The little wheel/cog piece on the right bottom rear of the ski. This is for a 2006 RXT. The wheel barely turns, feels as if bearings are gone - I've checked, but don't see anything jammed up in there. I know it's not 100% accurate, but I'd like my speedo to work correctly.

    What am I looking at labor-wise to replace it? Looks like 3 screws to be removed from the outside... maybe just a new part, reconnect some wires and silicone and re-attach?

    - please.
    I am sure you can do it yourself. Just a couple screws holding the housing on. Then there is right stuff sealent holding the speedo housing to the hull.

    To get the wires through you will need a tool to remove the connections from the weatherpack connector. It then slides right out.

    Dont forget that sender is also your lake water temp gauge.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	wetherpack.jpg 
Views:	43 
Size:	60.8 KB 
ID:	182114  

  3. #3
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308
    Quote Originally Posted by mrbtd View Post
    I am sure you can do it yourself. Just a couple screws holding the housing on. Then there is right stuff sealent holding the speedo housing to the hull.

    To get the wires through you will need a tool to remove the connections from the weatherpack connector. It then slides right out.

    Dont forget that sender is also your lake water temp gauge.
    OK, sounds easy enough. So after the screws come out, do I use something like a putty knife to help separate the unit from the hull? (I'm guessing the "right stuff" will still be bonding.)

    Then I need a long, tool to remove the wires. Next is replace unit, reconnect wires, apply new sealant and re-attach to ski.

    BTW: Are their bearings on each side of the wheel axle? Why does it feel like it's in a bind or what generally causes this to happen? I'm asking b/c this is the 2nd time this has happened on the same ski, and I've got two identical RXTs.

    Thanks for your help.

  4. #4
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    I'm not sure if there are bearings in there or not, but it could be something as silly as sand creating a bind.

  5. #5
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308
    I've been thinking that may be it too, Jeremy. Have you ever had a problem w/yours?

    So far, all I've done is stick my finger in between the wheel & housing, but no foreign matter is to be found. When I get home tonite, I'm going inspect it real closely: I'll try blowing air in and around the "axle" and where it meets the housing and then I'll try some WD-40...

    ...then I'll order a new part: $133.!!!

  6. #6
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038
    guys- I have a similar issue. Don't know if its a bearing or bushing or just a hole drilled into the mounting housing, but either way the hole is enlarged, wobbles and doesn't spin freely. Can purchase the parts seperately and the speedo'a aren't accurate anway. I'll just keep driving my 50 mph rxt (with an x-charger)

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Check with Parker Yamaha. I repalced the one on my RXT 2 years ago. Dont remember exactly what I paid, but its was alot less than $133.

  8. #8
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308
    Quote Originally Posted by Dirty Sanchez View Post
    guys- I have a similar issue. Don't know if its a bearing or bushing or just a hole drilled into the mounting housing, but either way the hole is enlarged, wobbles and doesn't spin freely. Can purchase the parts seperately and the speedo'a aren't accurate anway. I'll just keep driving my 50 mph rxt (with an x-charger)


    "No, really! it only goes 50 mph - check it out for yourself." Sandbagger...
    That's funny Sanchez. But you're prob. like me, you just want your stuff to work properly. I'll investigate tonite and report back the findings...

    Quote Originally Posted by troyheb View Post
    Check with Parker Yamaha. I repalced the one on my RXT 2 years ago. Dont remember exactly what I paid, but its was alot less than $133.
    Do you have any other install notes or tips?

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    mrbtd summed it up pretty well, its not really too difficult. I pulled the old unit away form the back of the ski then cut the old wires but you may not need to do that. From what I remember I called Parker and was naming off the parts I wanted and the guy said they had a kit that had all the parts in it for around $70. Dont quote me on that price though. lol

  10. #10
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308
    Well I found this: http://www.parkeryamaha.com/seadoosp...uresensor.aspx

    But it's for a 2006 GTI or newer; I'm an '06 RXT.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Baffle Sending Unit Repair !
    By RX951 in forum 2-Stroke Performance
    Replies: 128
    Last Post: 09-11-2016, 07:15 AM
  2. Fuel Baffle Sending Unit Repair !
    By RX951 in forum Sea Doo How To & FAQs
    Replies: 20
    Last Post: 09-07-2012, 07:05 PM
  3. fuel sending unit fix (gas gauge)
    By hotrod_sxty8 in forum 2-Stroke Performance
    Replies: 32
    Last Post: 07-15-2011, 04:18 PM
  4. gas gauge? sending unit? i need some help
    By juggaloXPracer in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-21-2007, 05:06 PM
  5. Plastic Welding & Fuel Sending Unit Repair Info
    By RX951 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 03-14-2006, 06:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •