Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 58
  1. #1
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24

    wont exceed 7000 rpms or 60 mph

    I have just installed a 3in intake to the super charger and the spectre filter. Today when I started the ski and took it on the lake for the first time it would not exceed 7000 rmps, or 60 mph.. and at sometimes it would sputter. I ran it for about an hour with no change??? It had a half tank of gas in it from last year, and i filled it the rest of the way. I put stable in it but I think it was like two months after due to the fact that the ski was gone for a OIL CHANGE.... What do or did I do?????


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    fresh gas, new plugs and check sc slip would be my first things to check.

  3. #3
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Quote Originally Posted by Dockside View Post
    fresh gas, new plugs and check sc slip would be my first things to check.
    Supercharger SLip? how do i check that?

  4. #4
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Quote Originally Posted by Dockside View Post
    fresh gas, new plugs and check sc slip would be my first things to check.
    also what plugs do I need to get and gap dist?

  5. #5
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    they are pre-gaped and it's probably your gas

  6. #6
    hopefully you didnt do any damage, but why do people continue to ride their ski when it is not running properly? hoping it will "clearout"... jet ski's dont fix themselves.. by continuing to ride it, i see more motor rebuilds in my shop that wouldve been a simple fix, had it not been riding for additional time..

  7. #7
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by faster7581 View Post
    hopefully you didnt do any damage, but why do people continue to ride their ski when it is not running properly? hoping it will "clearout"... jet ski's dont fix themselves.. by continuing to ride it, i see more motor rebuilds in my shop that wouldve been a simple fix, had it not been riding for additional time..
    well im guessing his ski ran fine befor it was winterized so should be something simple like gas and plugs. as long as the supercharger didnt fail it should be fine.

  8. #8
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24

    Ahhgg

    So new gas didn't help. I don't hear the sc whinning up ither. Is there any way to check if it is the sc and what would do that. It ran great last year. Plus I had it to the dealer year before to have the sc washers changed. This suks I only get to 7000 rmps and no more but it sounds smooth

  9. #9
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by alex_baker202 View Post
    I don't hear the sc whinning up ither.


    Pull the intake hose off of the supercharger and see if you can spin your supercharger wheel by hand. Report Back.

  10. #10
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Quote Originally Posted by craigo View Post


    Pull the intake hose off of the supercharger and see if you can spin your supercharger wheel by hand. Report back.
    yes i can spin it by hand.....

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 09 Ultra 260 wont rev past 7000 rpm
    By CayRider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-22-2015, 12:37 PM
  2. Replies: 6
    Last Post: 08-23-2014, 10:04 PM
  3. Replies: 7
    Last Post: 07-05-2012, 04:36 PM
  4. 2008 RXP-X will not exceed 6780 rpm's or 60mph
    By MST in forum 4-Tec Performance
    Replies: 12
    Last Post: 10-04-2010, 09:20 PM
  5. 97' 1100 STX wont rev high rpm. Sounds like cylinder not firing sputters over 30 mph
    By hooptyride in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-21-2010, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •