Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193

    ski taking a while too start

    Ok i have an 2010 fzs with 16 hours
    and it is taking a while to start , turns over fine but about 10 secs to fire
    when it fires it runs sick for a couple of secs before cleaning up and running fine
    this is happening every time hot or cold
    my thoughts at the moment are a faulty injector leaking fuel and flooding the motor
    because if i kill the motor and fire it back up it starts straight away
    but if i wait for more than 30 secs it takes time to fire again

    what are peoples thoughts, it started doing this at 13 hours about half an hour after after a tank refill from empty (buzzer on)

    kev


  2. #2
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    any mods at all?

  3. #3
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    Mods are Riva manifold upgrade,Riva air pipe and filter, riva exhaust
    R&D intake grate, VX ride plate

    kev

  4. #4

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    Leaky injector.

  5. #5
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,130
    +1
    205
    I had a somewhat similar problem when my oil was overfilled. Ski would idle rough and take a few extra seconds to fire. Also, when I would rev it on the trailer and let off of the throttle it would sometimes shut off.

  6. #6
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    oil level is fine
    once ski clears itself on startup it runs fine all the way to top speed
    i was hoping that some full throtle riding would clear it up but no such luck

    kev

  7. #7

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527
    repace the sparkplugs first!!!!!!!!!!!!!!!

  8. #8
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    if an injector is the problem, pulling the plugs after waiting a few mins (per your post) should help identify the leaking injector(s).
    One or more plug will likely be wet with fuel.

  9. #9
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112
    Quote Originally Posted by 2fast4u View Post
    repace the sparkplugs first!!!!!!!!!!!!!!!
    +1 I had the same problem and I changed the plugs and it was fine..but then it's hard seeing why plugs would be bad at only 16 hours

  10. #10
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    This could be silly , but when my brother use to ride my FZR , he use to try and start mine with the throttle down alittle and it just cracked and didnt start.

    Just putting it out there.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ski takes on water while not sitting in the water......
    By Anger_Mgmt in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 11-05-2012, 01:57 PM
  2. 1996 Polaris jet ski taking on too much water
    By april in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-16-2011, 07:57 AM
  3. 99 XLT Stalls and takes a while to start
    By joeg12345 in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 08-19-2009, 07:12 PM
  4. X skis take on water?
    By driveumhard in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-18-2008, 08:08 PM
  5. Modified Blaster and SJ take note:(Others too maybe)
    By LT1GMC in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 08-15-2007, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •