Results 1 to 4 of 4
  1. #1

    help starting problem

    can any one help us with this problem from cold the ski starts fine, after 15 minutes running when you put key on post and try to restart dashboard goes blank and will not turn over. when ski cools down will start fine.
    please please please help any ideas
    2002 gtx 4tec

  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Dayton, OH
    Start simple by schecking bat connections. Then check all grounds and other connections for corrosion

  3. #3
    that all done starter checked all pins clean and ok battery fully chargerd could it be the starter relay are there any tell tale signs when these break down thanks howard

  4. #4
    im having the same problem please help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SP starting problem
    By needforspeed04 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-20-2008, 08:00 AM
  2. starting problem :|
    By nonvtecdaturbo in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 12-12-2007, 09:48 PM
  3. starting problem, help needed!!!
    By auris1 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-27-2007, 02:24 PM
  4. 04 RXP Starting problem
    By GTGRXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-06-2007, 07:01 AM
  5. starting problem
    By ercoach in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-01-2007, 10:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts