Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353

    04 RXP Bad Cavitation at start

    Went out today with a buddy, his 04 RXP seems to have Really bad cavitation (or so it feels ) out of the hole, once above 20mph it screams! Replaced wear ring and prop (stock) no change.
    Top speed about 69 *seadoo speedo at 7600 RMP

    What else could be causing this bad cavitation out of the hole?

    Thanks!


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    did you check the carbon seal?

  3. #3
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by Dockside View Post
    did you check the carbon seal?
    +1

  4. #4
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    whats the best way to check the carbon seal?
    Thanks!

  5. #5
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by jekvall View Post
    whats the best way to check the carbon seal?
    Thanks!
    Put a new bellows, float ring, and carbon seal on the ski.

  6. #6
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    Thanks! Will give it a try ASAP! Anything else we could possibly be overlooking?

  7. #7
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by jekvall View Post
    Anything else we could possibly be overlooking?
    Yeah, is there anything pressing on the carbon seal bellows?

  8. #8
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    how many hrs on the ski?

  9. #9
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    I believe around 68 hours on the ski.
    Will try to check the carbon seal visually soon.

  10. #10
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    if its an 04 and is only turning 7600 RPM you need to see if its had that knock sensor upgrade and the ECM reflashed. If it hasent been done properly it will only turn 7600 RPM
    Quote Originally Posted by jekvall View Post
    Went out today with a buddy, his 04 RXP seems to have Really bad cavitation (or so it feels ) out of the hole, once above 20mph it screams! Replaced wear ring and prop (stock) no change.
    Top speed about 69 *seadoo speedo at 7600 RMP

    What else could be causing this bad cavitation out of the hole?

    Thanks!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 07-02-2010, 01:35 AM
  2. 04 RXP Question about a (Sensor) light coming on display at start up?
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-01-2010, 07:57 PM
  3. 04 RXP Starting problem
    By GTGRXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-06-2007, 07:01 AM
  4. Bad switch or starter problems on 04 RXP.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-22-2006, 12:53 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •