Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    1995 seadoo xp vts trim PLEASE HELP!!!!

    just bought this 1995 xp 720 and love it so far just got the crabs rebuilt and running strong next thing on the list is my trim isnt working but when i turn the ski on and hit the trim switch i can hear a clicking noise in the vts box so i know the switch is working what should i do next no idea please help thanks!!!!


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Here is a link to an online service manual. You need adobe reader to use it. Make sure you are not getting water into the box. The boot in the back needs to be in good shape and tight.

    http://www.mediafire.com/?jzj1m1xzndm

  3. #3
    there is no water at all in the box i have opened and looked inside it looks brand new and dry boot is good

  4. #4
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Well the motor is bi-directional. What that means is depending on what terminal receives +12v makes it go up or down. First place I would start is at the motor. Easiest to get to. Un-clip the connector and take a test light, a volt meter would be more accurate, to it. Make sure you clip the ground lead of the test light to the other terminal and hit the switch in both directions. Verify it lights both ways or you see a +12v and -12v. That would be a place to start.
    Last edited by RumRunnerRon; 04-12-2010 at 03:36 PM. Reason: add info

  5. #5
    When i picked up my 96 gsx last year i had vts troubles too. Make sure that your (i believe 7v) fuse is not blown. I believe it will still click without the fuse blown. If its blown replace it and see how that goes.

  6. #6
    thanks alot guys i am getting off work now so im going home to try both of these i really appreciate the advice will be back to let you know how it goes

  7. #7
    so i checked it last night and the fuse was blown so i replaced but it just blew right away so i put another fuse in and disconnectd the motor wires and fuse did not blow which led me to believe it was motor related to i then removed the motor nd sure enough it was locked up so i will be in the market for a new one thanks again guys

  8. #8
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Sweet. Hope that fixes it for good.

  9. #9
    You can save yourself $100 dollars and probably fix it yourself. First, take a rubber mallet and smack it where the gear is a couple good times. Open the housing on it and spray some pb blaster where the gear is. Next Pull out the worm gear and regrease that. Solved my problem and it was free

  10. #10
    yea i took the motor all apart and tried just about everything to save it but i thinks its just pretty much shot ill give it another look tonight though thanks again guys

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts wtb vts gauge and tach gauge for a 1995 seadoo xp 720
    By dan725 in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 06-30-2014, 09:21 PM
  2. 1992 Seadoo XP no Spark please help
    By lleafs in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-13-2013, 07:14 PM
  3. newbie needing help 1995 seadoo XP
    By Tmacey in forum 2-Stroke Performance
    Replies: 25
    Last Post: 04-29-2013, 08:37 PM
  4. 1995 seadoo xp trim
    By SeanPreston10 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2012, 12:25 PM
  5. 03 seadoo xp di problems Please help
    By macattack in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-21-2009, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •