Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Join Date
    Sep 2007
    Location
    pensacola
    Posts
    30

    my Solas prop ripped

    I installed a solas prop in my 08 sho.When I was out running it I thought i had sucked up something but when I got it out the prop had ripped and no evidence of hitting anything. looking at the prop closer it looks as if there was a stress crack about an inch or more on the blade were it had ripped.looks like cheap stainless steel when you look at and feel the stock prop.Anybody heard of this problem with the aftermarket sho props?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	solas 001.jpg 
Views:	107 
Size:	604.9 KB 
ID:	182945   Click image for larger version. 

Name:	solas 002.jpg 
Views:	94 
Size:	692.1 KB 
ID:	182946  


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527

    Question

    That looks like a prop that had a casting defect in it OR a prop that has been re pitched too many times causing the blade to crack. How many hours are on this prop? Has it ever been repitched? Did you buy it new? What prop # id this prop (brand and pitch)? Answer these questions Please, Tommy Jordan

  3. #3
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,795
    +1
    2,010
    +1 on what Tommy said.

    I've seen this before with a Solas. A friend of mine had one break a blade clean off on his FX160. The broken blade got wedged between another blade & the wear ring...gouged the wear ring & actually broke the intermediate shaft in half. Consider yourself lucky you'll only be replacing the prop.
    http://greenhulk.net/forums/showthre...light=impeller

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    I have had 2 boats in my shop with dynaflys where the blade cracked and/or broken off

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    If you bought it new I would bet Solas would stand behind it.

  6. #6

    Join Date
    Sep 2007
    Location
    pensacola
    Posts
    30
    Quote Originally Posted by 2fast4u View Post
    That looks like a prop that had a casting defect in it OR a prop that has been re pitched too many times causing the blade to crack. How many hours are on this prop? Has it ever been repitched? Did you buy it new? What prop # id this prop (brand and pitch)? Answer these questions Please, Tommy Jordan
    that prop has less than 10 hrs on it.It happened during an acceleration from no wake.
    Its rivas dinafly for the sho.I have other solas props for other skis that preformed great.I wonder if solas has really built these props for the amount of tork that the sho puts out. And yes the pump housing got it too!!!

  7. #7
    HighVelocity's Avatar
    Join Date
    Jan 2008
    Location
    Clear lake area, TX
    Posts
    162
    Quote Originally Posted by 2fast4u View Post
    That looks like a prop that had a casting defect in it OR a prop that has been re pitched too many times causing the blade to crack. How many hours are on this prop? Has it ever been repitched? Did you buy it new? What prop # id this prop (brand and pitch)? Answer these questions Please, Tommy Jordan
    How many times was it re-pitched? Are you sure you didn't hit anything? I broke a blade off mine for the gpr but it had several re-pitches and about 150 hrs. and Oh yes I hit a sand bar! Impros repaired it good as new.
    Last edited by HighVelocity; 04-13-2010 at 08:12 PM. Reason: grammar

  8. #8

    Join Date
    Sep 2007
    Location
    pensacola
    Posts
    30
    Quote Originally Posted by HighVelocity View Post
    How many times was it re-pitched? Are you sure you didn't hit anything? I broke a blade off mine for the gpr but it had several re-pitches and about 150 hrs. and Oh yes I hit a sand bar! Impros repaired it good as new.
    never been re pitched, went from the box to the ski.Im pretty sure I didnt hit anything,couldnt touch bottom, and there was nothing floating, and no hits on the prop

  9. #9

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527
    Quote Originally Posted by dbone View Post
    never been re pitched, went from the box to the ski.Im pretty sure I didnt hit anything,couldnt touch bottom, and there was nothing floating, and no hits on the prop
    Sounds like a defective prop to me. I hope they will replace it at no charge to you! Let us know how you come out on this. Tommy Jordan

  10. #10
    HighVelocity's Avatar
    Join Date
    Jan 2008
    Location
    Clear lake area, TX
    Posts
    162
    Quote Originally Posted by 2fast4u View Post
    Sounds like a defective prop to me. I hope they will replace it at no charge to you! Let us know how you come out on this. Tommy Jordan
    +1

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. solas prop compared to stock repitched
    By nitro rxp in forum 4-Tec Performance
    Replies: 23
    Last Post: 12-17-2007, 10:31 AM
  2. Repitching solas prop for more RPM
    By nitro rxp in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-30-2005, 09:01 AM
  3. Solas prop & steel wear ring kicks ass
    By nitro rxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-29-2005, 11:49 PM
  4. solas prop?
    By nitro rxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-27-2005, 04:47 AM
  5. solas prop
    By nitro rxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-08-2005, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •