Results 1 to 7 of 7
  1. #1

    polaris virage limp mode?

    2002 polaris virage (700) I just installed a new motor and blocked off oil pump. I have not done anything to the oil reservoir which is empty. When I started the ski it would idle then as I reved it up it would hit the rev limiter and begin to bog then backfire. Does the low oil light trigger a limp mode that is causing the ski to hit the rev limiter?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Do you have the MFI display connected?
    Any red lamp or messages on the display?

    The 2002 Virage will RPM limit at 3500RPM in Reverse and Neutral, and during overheat. Both should show messages on the display.

    There is a reverse sensing switch mounted on the bottom of the reverse lever mechanism.

    The overheat sensor is mounted on the exhaust, and has a Tan wire.

  3. #3
    There is a red flashing light that looks like an oil light. Like I said there is no oil in the reservoir. Everything was reinstalled just as it came out other than the oil pump.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Quote Originally Posted by chrisdoc0608 View Post
    There is a red flashing light that looks like an oil light.

    Like I said there is no oil in the reservoir.

    Everything was reinstalled just as it came out other than the oil pump.
    You can bypass the oil warning. For now, just hook up the oil sender, and tie the float up so the oil warning goes away.

    The better fix is to get a 33 ohm resister. Crimp spade connectors on the resistor leads, and connect it between the Black and Blue terminals in the electrical box were the oil sender used to connect.

    33 ohms is the normal signal for a full oil tank

    The MFI display can also show messages, not just the red light. Press the Display button if needed to see the message.

  5. #5
    ok problem solved... i also had the reverse engaged

    now that it is running, i have noticed a fuel leak from the diaphragm side of the carb. I took it off and inspected it and I am seeing two holes. The first is on the plate where the diaphragm is, it is a round hole. The second is more of a square hole and it is on the plate that the jets are screwed into. It appears that the fuel is coming out of the square hole. I can clearly the hole is not obstructed or blocked by anything on the inside so I am confused as to why it is like this. I have a few keihin carbs laying around that are the smaller version and they too have this hole but it is blocked off by the castings inside of the carb.... what am i missing?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    If the carb is leaking, then take it apart and rebuild it with a new diaphragm, etc.

  7. #7
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by chrisdoc0608 View Post
    ok problem solved... i also had the reverse engaged

    now that it is running, i have noticed a fuel leak from the diaphragm side of the carb. I took it off and inspected it and I am seeing two holes. The first is on the plate where the diaphragm is, it is a round hole. The second is more of a square hole and it is on the plate that the jets are screwed into. It appears that the fuel is coming out of the square hole. I can clearly the hole is not obstructed or blocked by anything on the inside so I am confused as to why it is like this. I have a few keihin carbs laying around that are the smaller version and they too have this hole but it is blocked off by the castings inside of the carb.... what am i missing?
    I'm not sure why they have that opening, but I do know if the o-rings at the screen/needle-seat leak,fuel comes out that opening.

    As K suggested, a rebuild kit will include that o-ring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Virage limp mode
    By CMS in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-15-2015, 09:15 AM
  2. 1997 Polaris sltx "limp mode" questions
    By japjrthib in forum Polaris Open Discussion
    Replies: 10
    Last Post: 03-16-2014, 11:35 PM
  3. Information on 1992-1998 polaris in limp mode
    By Chuck785 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-13-2011, 08:34 AM
  4. 03 Polaris MSX 140 Limp Mode Problem
    By sbquality in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-28-2007, 10:32 AM
  5. Limp Mode H2O Temp Sensor Polaris MSX 140
    By H20Carver in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •