Results 1 to 6 of 6
  1. #1

    gp1200 starting issues

    Hello, I went to start my '97 gp1200 today and had some issues. The starter is like stuck on. It keeps cranking. I had the ski in the garage getting ready to go just making everything was good so I was able to disconnect the battery quickly. As soon as I connect the battery it starts to crank again without pushing the start button. Any ideas on what causes this? Bad switch or something? Any help would be great. Thanks.


  2. #2
    I wanna go FAAAAASTer!! CDW78's Avatar
    Join Date
    Mar 2010
    Location
    Ky
    Posts
    543
    +1
    6
    Id try disconnecting the start switch and reconnect the battery, if it doesn't turn over, it'd be safe to say your start switch it stuck on. Can try to take it apart and clean it, but not sure if you can clean to much of the internals. Could be a bad starter too, I suppose....

  3. #3
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    It's the starter relay has died inside the ebox....change it out and you will be fine =0)

    Mike

  4. #4
    Yeah I figured it out after a bit. Best place to get one?

  5. #5
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170

  6. #6

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 gp1200 Starting electrical issues
    By Derek1 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-08-2013, 09:29 PM
  2. 2000 gp1200 starting/running issues
    By johnny p in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 06-04-2012, 09:04 PM
  3. 98 GP1200 Starting and Running Issues
    By renee in forum Yamaha Old School Skis
    Replies: 14
    Last Post: 07-09-2008, 08:49 AM
  4. 98 GP1200 Starting and Running Issues
    By renee in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 06-09-2008, 01:11 AM
  5. Starting issue or not?
    By GPR FL in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-01-2006, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •