Results 1 to 6 of 6
  1. #1
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45

    Those with 06+ 4-Tec engines in a Conversion

    Firstly i would like to thank both Damian (Autosport) And Rich (Richieb)
    for finding this problem and bringing it to our attention..

    they have found that on 06+ 4-Tec engines the scavenge pump housing is more pronounced and can rub on the conversion mount.. in doing so causes a vibration and possibilty of the grub screw walking out and giving a oil leak (if not rectified in time would cause damage to the scavenge pump housing ) you will find the pump housing sits directly on the mount in most cases...


    this is what i did to rectifie the problem , there may be better ways i believe, this is what rich did on damo's ski or something similar... welded in a piece of solid ss round bar to retain the integrity of the mount and scalloped out the side that meets the scavenge pump housing, hope this helps someone else ..


    regards Robert
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mount rubbing.JPG 
Views:	69 
Size:	97.5 KB 
ID:	183537   Click image for larger version. 

Name:	P1010093-Optimized.jpg 
Views:	61 
Size:	101.4 KB 
ID:	183538   Click image for larger version. 

Name:	P1010094-Optimized.jpg 
Views:	58 
Size:	99.4 KB 
ID:	183539   Click image for larger version. 

Name:	P1010096-Optimized.jpg 
Views:	48 
Size:	70.2 KB 
ID:	183540   Click image for larger version. 

Name:	P1010097-Optimized.jpg 
Views:	54 
Size:	59.1 KB 
ID:	183541   Click image for larger version. 

Name:	part.jpg 
Views:	61 
Size:	57.8 KB 
ID:	183542  

    Click image for larger version. 

Name:	modified mount.jpg 
Views:	64 
Size:	106.4 KB 
ID:	183543   Click image for larger version. 

Name:	modified mount2.jpg 
Views:	60 
Size:	107.0 KB 
ID:	183544  


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Sticky this please.

  3. #3
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Might be a little bit of overkill but nice work. I just notch that area with a grinder. Remember this isn't OEM but backyard redneck whitetrash enginuity!!! If shit doesn't fit perfect make it happen!!!

  4. #4
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    can anyone confirm if this is also needed on my mounts?

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Yup.

  6. #6
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    ttt

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 98 XPL with a 99 951 engine in it!
    By BlackHawk in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 10-18-2010, 07:31 AM
  2. Polaris Jet Ski SLT 750 with a Kawasaki 750 engine in CA
    By 800AMSOIL4U in forum Polaris Skis
    Replies: 6
    Last Post: 09-02-2009, 10:28 PM
  3. WTB: 06 4-tec engine and all electrical etc. for conversion
    By jeffsntx in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 07-14-2008, 12:25 PM
  4. for those with 06' boats and leightweightcam gear?
    By beachboy66 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-06-2006, 02:48 AM
  5. I want to put my 4-tec engine in this
    By NCHeel in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-20-2006, 01:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •