Results 1 to 7 of 7

Thread: Need Help ASAP

  1. #1

    Need Help ASAP

    Ok a few weeks ago i posted how went out for a bit and when i pulled my drain plugs i have a little water come out then like a QT of oil. Well i pin pointed it today. Its pushing the seals on the oil filter cap out. When if i just start it off the hose in the drive way it pushes it out Right away and oil starts flowing out. I picked up new seals today still the same thing happen. The cap its self looks good But it has a tap broke off the inside but i think the tap is just to help guide the bolt through the top. I have all 3 seal on it. What would causeing this?

    2002 GTX 4 tec 155 N/A


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    A broken tap on the inside I think I'd replace that cap, and see where you are then!

  3. #3
    Quote Originally Posted by bigdaddyRXP View Post
    A broken tap on the inside I think I'd replace that cap, and see where you are then!

    Ya i got on on order But its been like that for a while The o ring is on top the tab just a guide for the Bolt to go through. BTW were can i order a cap at? Im going to cancel the one here $45 for the cap is ........ Is there anything possible to cause this I tighten the bolt by hand the about a 1/4 turn with a wrench. So its not very tight 90 INlbs is what it calls for

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Is the filter new... sounds as if it could be clogged There shouldn't be near enough pressure in there to push the o-rings out Is it pushing all 3 side o-rings out... or the one on the bolt???

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Is your cap plastic or metal??? In the parts breakdown for an 02 GTX 4-TEC... the original cap appears to be plastic with only one o-ring on it. The newer caps are metal and have three o-rings

  6. #6
    Quote Originally Posted by bigdaddyRXP View Post
    Is your cap plastic or metal??? In the parts breakdown for an 02 GTX 4-TEC... the original cap appears to be plastic with only one o-ring on it. The newer caps are metal and have three o-rings

    New filter only has 2 hrs on it. My cap has 2 o rings on the side and one small o ring on the top of the bolt... Its pushing the top Big o ring the one you can see that seal the cap to the bore...its pushes it out both side lol

    I ordered the new cap just now.....

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Order a new bolt o-ring as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help ASAP
    By SeanJ in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-29-2007, 06:06 PM
  2. Need Help ASAP
    By Yellow04RXP in forum 4-Tec Performance
    Replies: 39
    Last Post: 05-17-2007, 01:48 PM
  3. Need help ASAP pro cdi wiring....
    By Rodneyae in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-05-2007, 08:58 PM
  4. need help asap!!! please
    By nonvtecdaturbo in forum Polaris Open Discussion
    Replies: 23
    Last Post: 12-12-2006, 08:11 AM
  5. Need help ASAP!
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 07-05-2006, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •