Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Nasty Caviation...WTF!!!

    Well after I got the oil pressure thing figured out and the engine put back in still having problems I was before. When I first got the ski about a year ago it had the same problem but has been getting worst. When you take off it sounds like your burning rubber off tires but then once it catches it screams. I was running 8100 RPMS and not loosing any top end. I just have no bottom end. THe wear ring has the really deep grooves in it and the prop has nicks in the blades will this cause it ?


  2. #2
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    yes and your carbon seal on the drive shaft could be sucking air into the pump tunnel

  3. #3
    Quote Originally Posted by idoodou View Post
    yes and your carbon seal on the drive shaft could be sucking air into the pump tunnel
    Engine was aligned and the carbon seal and little hat and bellow are brand new

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    A worn wear ring will cause cavitation.

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    A new wear ring will fix most of that Bro. I have been there before.

    They are easy to change to with the freezer method.

  6. #6
    Quote Originally Posted by Ocman View Post
    A new wear ring will fix most of that Bro. I have been there before.

    They are easy to change to with the freezer method.

    Should I replace it with the original one or the new one that kind of needs pressed in

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by greens1098 View Post
    Should I replace it with the original one or the new one that kind of needs pressed in

    Buy one out of the store here and check the how to section bro

  8. #8
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    Quote Originally Posted by greens1098 View Post
    Should I replace it with the original one or the new one that kind of needs pressed in
    There is a procedure in the "how to" section on how to swap the wear ring out. Basically, take the pump off and put it in a freezer for about an hour. Take it out of the freezer, then remove the impeller and the wear ring will probably fall out with the impeller. (Aluminum and plastic freeze at different rates.) Put in a new OEM wearing ring, purchased from the Online Store, reinstall the impeller and pump. It really is easy to accomplish.

  9. #9
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You dont even have to change your impeller if you dont want to bro.

  10. #10
    Quote Originally Posted by Ocman View Post
    You dont even have to change your impeller if you dont want to bro.
    Alright cool, I mean can a bad wear ring really cause that much cavitation its like im burning some nasty rubber on a high hp car..

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Isoflex grease?!! Super lube?!! WTF?!!
    By 01xdime in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-06-2012, 01:39 PM
  2. oh hell, wtf.(howd dis happen)
    By HOSS in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-25-2006, 09:53 AM
  3. WTF... walmart doesnt sell gallong jugs of '2smoke oil...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-29-2006, 09:06 PM
  4. WTF chk engine beep
    By Carlos Miami RXP in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-22-2006, 08:26 PM
  5. RXP WONT FLOAT: WTF
    By HankC350 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-20-2005, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •