Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Beeeep Noise

  1. #1
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19

    Question Beeeep Noise

    My 2007 RXT beeps after riding it for about 30 min. One long beep then stops then 2 min later another long beep then 5 min later another long beep (the time between is estimated). I do all my own maintenance. Did the blend oil change last fall, changed plugs, crc 666 the engine, charged the battery, and use salt away when running it out. This is the 3ed year with this problem. Was told that its a maintenance code and has to be cleared for $50 by dealer. Its at the dealer and they just told me there is No code showing but they cleared the computer, do I want them to run it at $150 an hour to here the beep. Does anyone have the same BEEP problem.


  2. #2
    Any codes on the display with the beep?

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by Rick View Post
    My 2007 RXT beeps after riding it for about 30 min. One long beep then stops then 2 min later another long beep then 5 min later another long beep (the time between is estimated). I do all my own maintenance. Did the blend oil change last fall, changed plugs, crc 666 the engine, charged the battery, and use salt away when running it out. This is the 3ed year with this problem. Was told that its a maintenance code and has to be cleared for $50 by dealer. Its at the dealer and they just told me there is No code showing but they cleared the computer, do I want them to run it at $150 an hour to here the beep. Does anyone have the same BEEP problem.
    Does it go into limp mode or just beep? If its running fine other then the beeping, the only thing I can think of is you are getting a low fuel warning. Maybe a bad sender unit or connection.

  4. #4
    Quote Originally Posted by Rick View Post
    do I want them to run it at $150 an hour to here the beep. Does anyone have the same BEEP problem.



  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,272
    Quote Originally Posted by Rick View Post
    My 2007 RXT beeps after riding it for about 30 min. One long beep then stops then 2 min later another long beep then 5 min later another long beep (the time between is estimated)
    the service manual has specific times for these oddball beep codes 2 second beep every five minutes is pointing to a fault in the fuel tank level circuit or a low fuel level.

    2 second beep every 15 minutes points to a gaggle of more expensive issues, too painful and numerous to list. Of course I don't think you need a beep warning to tell you the ski is upside down ( one of the symptoms), but your tops system could be snookered into sending that signal

    tip: get digital voltmeter, check battery voltage

    tip#2, get the actual time between beeps..

    as a favorite pointy eared vulcan once said...minutes seem like hours..hours seem like days

  6. #6
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19
    no codes

  7. #7
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19
    its a looonng beep, i will check voltage. battery is the stock 07. never had aproblem with starting it. don't like the battery vent that leaked over the years and corroded the bolt washer and tray. thanks for info. I guess i will pick it up today for the dealer

  8. #8
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19
    well i got it and lost $50 to the dealer. Asked the question of the day ceramics. $300 parts 2 hours labor at 125 an hour. Wheres the MFG recall on this, maybe US Consumer protection needs a letter. checking battery Tuesday. Thanks all for help

  9. #9
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    you lost the washer in the charger? if so make sure you get the motor cleaned out

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,272
    Quote Originally Posted by Rick View Post
    its a looonng beep, i will check voltage. battery is the stock 07. never had a problem with starting it. don't like the battery vent that leaked over the years and corroded the bolt washer and tray.
    a lonnnnng beep is another issue. No documentation I have explains it but last time I had it the emm took a dump and the ski wasn't starting after a submersion. Could be a tops switch problem or a bad connection in the harness ( good luck finding that)

    supercharger washers are to be changed ever 100 hours these days. not a recall but a "wear item"

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. no drive and bad grinding noise
    By timbo in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-27-2006, 10:40 PM
  3. Supercharger noises
    By vxrpete8 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-28-2005, 07:03 AM
  4. Riva-Vortech SC Impeller---Noise
    By RXPDAVID in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-11-2005, 01:03 PM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •