Results 1 to 6 of 6
  1. #1
    tmackx's Avatar
    Join Date
    Mar 2010
    Location
    East TN
    Posts
    19
    +1
    3

    low rpm issue 03 gpr

    Had a friend ask about a low power complaint on a 1300. It will only do 50 at 6000 rpm. The power valves appear to be free, I can watch the shaft turn during the start up test. I didn't get a chance to ride this ski but I did ride a different on several years ago with the same symptom. Didn't get a chance to check out though. This ski has ~50 hrs on it.

    Any help would be appreciated.

    (Edit- sorry, 2004 model)

    Sean
    Last edited by tmackx; 04-20-2010 at 08:50 AM. Reason: wrong year


  2. #2
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20

    Re: low rpm issue 03 gpr

    Could be a lot of things? If you believe it's an rpm issue I would start by checking the compression. Then check powervalves.

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by Mike's GPR View Post
    Could be a lot of things? If you believe it's an rpm issue I would start by checking the compression. Then check powervalves.
    +1

    also could be a clogged catalytic converter

  4. #4
    tmackx's Avatar
    Join Date
    Mar 2010
    Location
    East TN
    Posts
    19
    +1
    3
    He said he had checked the compression. 105,105,110. I thought that was a little low for 50 hours. The pump should be in good shape. He said the rollers fell out of the rear housing when he removed the pump cone so he rebuilt the pump, including a wear ring, impeller shaft, impeller and so on. Forgive me for not having a lot of first hand info. I owned an 03 at one point. Bought it new and sold it at 36hrs. The neighbor across the cove bought it so I got to watch it run around on the lake for several years. Anyways I got a chance to ride it and noticed the rpm's would not go over 6000. I mentioned it to the own but he must not have done anything because the engine failed 6 months later. I was hoping this might have been a commen issue with low rpm's at 6000. Two ski's with the same symptom.

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    There are many things to check just with the powervalves ... if the servo motor works, thats good. If the wheel and both shafts move, thats good. IF the catcon is good or a D plate is in place, and the two above PV checks are OK, then pull the PV covers ... the PV might be broken at the neck, the pin might have fallen out, or a screw may have come out of the shafts. Either way, it is likely the PVs need a good cleaning out anyway.

  6. #6
    tmackx's Avatar
    Join Date
    Mar 2010
    Location
    East TN
    Posts
    19
    +1
    3

    Found it, game on!

    Get this, he found a sandwich bag covering one of the throttle bodies. Now his arms are an inch longer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Rxp low speed low rpms Issue PLEASE HELP!
    By redchev67 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2016, 02:57 PM
  2. Replies: 6
    Last Post: 08-02-2010, 10:01 PM
  3. Polaris SLH 700 Low RPMs and idle issues
    By polaris 700cc in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 07-07-2009, 09:22 PM
  4. Low RPM issue
    By sportman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 60
    Last Post: 07-11-2008, 03:36 PM
  5. Low RPM Issue
    By xenonx in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-19-2006, 03:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •