Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: Need Help!!

  1. #1

    Question Need Help!!

    Hey guys i bought a 97 tigershark yesterday, but the guy i got it off of says that the ski was running last year but shut down on him in the water so he pulled it out. He said it will still turn over but will not run any ideas on why this is and how i can fix it??????


  2. #2
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    This really could be a million things. If the engine is already out I would just start with all the basics. Its more then likely all the orginal parts for 97 so it really wouldnt hurt it to pull the motor all apart and check it out. If everything looks good put it back together with new crank seals, new piston rings, and new gaskets, and then move onto the carbs. It will not cost to much money doing it this was and also makes sure everything is good so your not getting towed back to the dock all summer.

  3. #3
    thats what i figured, this is my first shark and i couldnt pass it up for the price. the motor is still in the ski, so being that would it hurt to start at the carbs and work my way back through the lines before pulling the motor?

  4. #4
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    Yes if the motor is still installed start with the carbs. A comman thing to look for is the small filter inside the carb could be pluged. The small filter is #7 in this picture. http://www.atlanticjetsports.com/mik...dual_parts.htm

    There are a lot of other things in the carb you could check while its apart but start with that. If that filter is pluged it will let the carb fill up with gas slowy while its at idle and then as soon as you give it throttle the large amount of fuel needed cant pass through the pluged filter so the motor runs out of fuel and cuts out. Check these and report back.

  5. #5
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    Sorry I just read you post again. I thought you said it runs and then dies but now I see you said it doesnt run at all. Try to check if you have spark first. If you do then perform a compression check.

  6. #6
    ok compression is good, has good spark just cant get fuel to the carb. is there a fuel pump or is it a vacum system? i have pulled the fuel lines off the carb and tryed to suck the gas through but its a no go, so i replaced the in line filter. . .no change still no fuel.

  7. #7
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    leave all the fuel lines hooked up to the carbs. Remove the return like that goes from the carbs back to the tank. Blow in the return line. This should build pressure in the fuel tank. If you hear air coming out somewhere like the tank vent just plug it with your finger so that you can build air pressure in the tank. Doing this will force fuel up the fuel line and fill the carbs if everything is hooked up right. Keep blowing till you see fuel spitting out the return nipple on the carb that you removed the line your blowing in. After doing this the carbs should be full and ready to go.
    The carbs fuel pumps run of a pulse line from the engine crankcase which creates +/- pressure and forces the fuel pump diaphram move back and forth drawing the fuel from the tank up to the carbs. If there are any air leaks in the incoming fuel lines or system it will not run properly or not run at all. If you have a vacum tester you can test things like your on/res switch to make sure it doest leak. Also another common spot is the primer. The best thing to do would be to install the primer in the return line that way if it does leak it doesnt effect performance.
    Check back with what you find out.

  8. #8
    Ok I took the return line off like you said and blew through it, as you said the fuel came out the return line nipple. So its obviously getting fuel now but it still won't ignite or fire. It turns over and it has plenty of spark from both cylinders. Any ideas?

  9. #9
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    Does it have a primer. If so give it a few pump. If not take a small cap full of fuel and pore it down each carb and try it.

  10. #10
    Nope no primer. I tryed the fuel down the carb and still no change. it just sits there and cranks and cranks. there has got to be something im overlooking.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •