Results 1 to 2 of 2
  1. #1

    93 polaris sl 750

    I have a 93 polaris sl 750, and it has a rattling sound coming from the impellor area, but cant locate it. The impellor bearing still good. I seem to remember my cousins sl 750 doin the same thing when I was a kid.
    Any ideas?
    I am new to the how PWC world, so any help is good help


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Welcome to the Hulk

    Best to keep all your questions together for now, in one thread. This thread may get moved to the General forum, where it belongs

    Quote Originally Posted by Jackson23 View Post
    I just traded my old beat up truck for a 93 sl 750. it has a rattling sound while it idles, i checked the impeller just by trying to move it. and also my machine seems to bog so i replaced the fuel lines and fuel filters. It never had any check valves or vacuum.

    It runs fine in my back yard now, no more bogging.

    There where only 3 houses coming off the fuel tank. The back 2 on front left when you are standing in front of it. the front left had a T on it and one hose just hung down with a screen on it, and the other went up to tank under the gauges. so i removed these line and plugged the one off the tank.

    And it runs good, but in my back yard lol.

    Ill admit i don't know much bout these things, but i am mechanically inclined.
    Any feed back would be great thanx!
    Quote Originally Posted by Jackson23 View Post
    I just went and looked at my ski, and looking at the front of the ski, I got the lines wrong on the tank.

    The front 2 run to the on/off/reserve valve, and the back left runs to the fuel pump etc. The back right is the one that is plugged. Sorry, thanx again
    Polaris did some changes to the fuel tank venting over the first few years. Have a look at the 1995 fuel venting configuration.

    The links below should be helpful...

    Polaris Industries Parts cross referencing system

    Polaris Fuji (blue) engine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris SLT 750
    By GrantBlaz in forum Polaris Open Discussion
    Replies: 7
    Last Post: 02-20-2009, 09:48 AM
  2. 1996 Polaris SLX 780, 1995 Polaris SL 750, and double trailer
    By kcoleman10 in forum Polaris Classifieds
    Replies: 6
    Last Post: 04-26-2008, 05:27 PM
  3. 94 Polaris 750 SL HELP
    By triker in forum Polaris Open Discussion
    Replies: 3
    Last Post: 02-29-2008, 12:57 PM
  4. 95 polaris sl 750 help
    By scottr2200 in forum Polaris Open Discussion
    Replies: 44
    Last Post: 07-09-2007, 08:33 PM
  5. my 94 polaris 750 will not start!
    By ducatifreak152 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 06-03-2007, 12:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts