Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Problems w/ wallbro fuel pump

    I need some help
    i replaced mine OEM fuel pump for an WALLBRO GSS 342.
    after 10 minutes of riding my ski starts shuting off...than start the engine put some throtle and 1 minute later shut off again and so on.....
    what could be?
    thanks
    Hugo


  2. #2
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    Are you using rrfpr?

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    What year is the ski?

  4. #4
    no i don´t use the rrfpr and the ski is 2007 one

  5. #5
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    If you are using HO fuel pumps you MUST use rrfpr or fuel controller

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by boBO View Post
    If you are using HO fuel pumps you MUST use rrfpr or fuel controller
    That does not make sense to me. Can you elaborate?

  7. #7
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    Will, I would like to elaborate to you but my English is not that good

    I hope any another member well explain this for you
    Sorry bro!

  8. #8
    the walbro is brand new....bougth from summitracing

  9. #9
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    The problem not from the Walbro fuel pump the issue is you have alllllot of fuel uncontrolled and if you have A/R ratio gauge you will find that you are running Soooo rich

  10. #10
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    You know what just pull one spark plug you will find allot of carbon on it from running rich

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 10-02-2010, 01:23 PM
  2. Polaris Virage fuel pump problems...
    By christical in forum Polaris Open Discussion
    Replies: 10
    Last Post: 02-15-2009, 12:06 PM
  3. Fuel Pump Problems
    By Hugofromlp in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-19-2008, 04:16 PM
  4. new guy with problems with fuel pump
    By crazuri2 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 07-24-2008, 07:34 PM
  5. Fuel Pump Problem 4 Tec
    By JeffSki in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-19-2008, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •