Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169

    Porposing and very squirrely

    I have a stage one 08 RXP, thru hull and block-offs ($100 ones).

    Today air temp was 52, lake was calm, RPM's 8020-8100. Best top speed was 70.1. Went out a few days ago...air temp was 70, little choppy, RPM's were a little lower and top speed was 70.3. Same porposing and too squirrely both times.

    You can't hold WOT for very long or you will get thrown off. Even on a calm lake today it was ridiculous. I probably have a little more RPM's and speed, if I could hold WOT. Half tank of gas.

    I did some searching. Some people seem to mention the wedge can cause this, but nothing seemed definitive. Maybe the block-offs, should I have forked out for the expensive ones? I will, but only if it will for sure solve it. I can't bring myself to spend that much on Riva's gold. My acceleration is so much better over stock with the mods, but I had more fun when it was stock and predictable. Winter mods were wedge, prop, thru hull and block-offs. Everything was fine last summer with grate and air intake. Grate isn't loose either.

    Anyone have any ideas? I want this fixed before summer hits.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Simple test... pull the wedge and see where you are

    Did you play around with trim settings, and did you add a longer VTS rod when you added the wedge

    The cheap block-offs weren't a good idea either

  3. #3
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    I did play with the trim settings, it almost goes away at full trim down (obviously scrubbing a lot of speed). I did buy the VTS ext. too. I really hope that it isn't the wedge. Wedge and extension is like $200 down the drain. I could have just bought the better block-offs then I just cannot believe the porposing is so bad. If it was the wedge, it seems everyone would have been getting rid of it, instead of just a few.

    I will give it one more shot next weekend, I'll take some tools with me to take it off at the lake if it is still there.

    Out of curiosity...those running the wedge and ext...what is the avergae sweet spot? 2 clicks above neutral still?

  4. #4
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Mine would porpos right at 70 when it was stock. have yet to test it since the mods.

  5. #5
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    Does the wedge actually add speed?? Did you just bollt it on with no tests. I get 70 with no wedge and I found that I only got a mph with a full tank. With a light load the Ski was more stable and faster. I also have at hop at top speed that I think is the worx grate. I had a warped intake shoe but installed a speed freaks insert after a little reworking.

  6. #6
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    So I read about the .30 shim in the back of the ride plate to help porposing. I just can't belive it is such a problem with my ski, it isn't that fast. And the feeling that it won't track straight is crazy. I will have to find some .30 washers as well. I am going to have to check out the pump area, make sure nothing is loose or something. Guess I will start saving for the better block-offs.

  7. #7
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    Quote Originally Posted by PEST! View Post
    Does the wedge actually add speed?? Did you just bollt it on with no tests. I get 70 with no wedge and I found that I only got a mph with a full tank. With a light load the Ski was more stable and faster. I also have at hop at top speed that I think is the worx grate. I had a warped intake shoe but installed a speed freaks insert after a little reworking.

    I put the wedge on at the same time as the prop, block-offs and thru hull.

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by PEST! View Post
    Does the wedge actually add speed?? Did you just bollt it on with no tests. I get 70 with no wedge and I found that I only got a mph with a full tank. With a light load the Ski was more stable and faster. I also have at hop at top speed that I think is the worx grate. I had a warped intake shoe but installed a speed freaks insert after a little reworking.

    The wedge and rod gave me a bit of speed. At least 1MPH. Im going to guess his problem is that he installed those with the cheaper blockoffs.

    My ski is smooth as silk knock on wood.

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    YOu should not have porposing issues on RXP until you get closer to 75 mph. Something else is wrong.

  10. #10
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    Quote Originally Posted by skoepp View Post
    YOu should not have porposing issues on RXP until you get closer to 75 mph. Something else is wrong.
    Agreed. I will check it all out this week and try it again this weekend.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jumped ship from seapoo and very happy 13 fx sho
    By Aussie04rxp in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 10-28-2014, 08:37 PM
  2. Leaked water into engine and very slow now
    By martinginnelly in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-09-2009, 01:48 PM
  3. 96 xp super hot pump shaft? and very odd vibration.....
    By jeffz0rz in forum 2-Stroke Performance
    Replies: 13
    Last Post: 04-29-2009, 06:15 AM
  4. Finally got my ski and VERY DISSAPOINTED!
    By GeoRXT in forum 4-Tec Performance
    Replies: 68
    Last Post: 12-27-2007, 07:07 PM
  5. I guess chew spit and cell phones do not mix very well
    By Jeff C in forum Open Discussion
    Replies: 8
    Last Post: 02-03-2007, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •