Results 1 to 3 of 3
  1. #1

    MSX 150 2004 Polaris

    My ski starts well, runs great, but will not hold a battery charge even with brand new battery. Could it be the voltage regulator? Where is it? Could it be anything else?


  2. #2
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    check the fuse in the back located near the ecu(silver box) in the fuse holders. Should be a 30 amp fuse. If blown chances are that you have a bad voltage regulator. It is located in the from of the engine under the intercooler.


    Jay

    P.S. We can get you a new on if needed. I may have a used one but I would much rather sell you a new one. Shop link is below....

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Welcome to the Hulk

    Jay has you on the right path

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cover MSX 150 2004
    By JLC in forum MSX/Matrix
    Replies: 3
    Last Post: 09-05-2011, 12:55 PM
  2. Paring out a MSX 150 2004
    By R rated in forum Polaris Classifieds
    Replies: 10
    Last Post: 12-21-2009, 11:36 AM
  3. 2004 Polaris MSX-150 4 Stroke - 23 Original Hours - Full Part Out
    By seatsR4toilets in forum Polaris Classifieds
    Replies: 6
    Last Post: 02-14-2009, 05:48 PM
  4. genesis 2001 or msx 150 2004
    By emailderek1 in forum MSX/Matrix
    Replies: 7
    Last Post: 02-07-2008, 10:22 AM
  5. 2004 Polaris msx 150 plugs turned silver after ten minutes help
    By Joe dana in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2007, 11:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •