Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338

    can someone give a quick break down on the piggyback

    Anything to keep in mind when installing the piggyback, dos or donts

    Are all the plugs located around the same place or at different points of the skis harness

    Looks straight forward but any info to make it easier and less guessing would be appreciated


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Did the guy that sold it to you not tell you how to hook it up?

    Its very easy to hook up. It plugs directly into your MAP sensor and CPS. The stock wire harness plugs into the other connectors on the fuel controller.

    Good luck and let me know if you need any more help.

  3. #3
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    Brian sent it to me after I bought it from frank, he mentioned a write up he was doing but I don't think he's done it because I never got a reply the last time I tried getting in touch with him. Honestly I would like something with some more detail like where to mount it and exactly where the plugs are located, if you get a chance and arent to busy Jerry when you get a chance if you could break it down I appreciate it

    Also where the screws are on it they spin freely inside so when I get around to tightening the bolts they spin is this normal, do they tighten up once I place it where it goes on the ski?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    This link will show you where it mounts
    http://www.greenhulk.net/blog.php?s=fuel+controller

    It mounts right next to the ECU.

    The MAP sensor is located on the intake manifold between the #3 and #2 intake runners

    The CPS is located on the back of the head.

  5. #5
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    Thanks for the info and link did you understand what I said about the screws?

  6. #6
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Excess, I know what you are talking about on the screws. I took the housing apart to mount it. That allows you to hold the screw heads in place when you tighten the nuts down. Attach the sensor leads before you mount it though. Mounting it first makes it hard to attach the MAP sensor lead.

  7. #7
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    Mine has a sticker on it that if I split it will break and it has to do with the warranty normally I wouldn't care but since its the first time on there I would hate for it to act up and then have to pay for a rolacement anyone else with any ideas on getting around this

  8. #8
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Mine has that sticker too. But because I couldn't get it tight because of those spinning screws, the allen bolts holding the housing rattled out and the housing came apart. So then I mounted it before putting the housing back together.

  9. #9
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    The Allen screws hold up fine now?

    Anyone else running the controller that did anthing different to tighten the screws without splitting it?

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You have to split it to tighten the screws

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can someone give a pin out of the 15 FZR ECU? Or explain....
    By SJ-(KY) in forum Yamaha ECU Support
    Replies: 1
    Last Post: 08-26-2015, 03:10 PM
  2. Replies: 11
    Last Post: 05-05-2013, 04:56 AM
  3. Can someone give me a Canadian Yamaha PWC Conformity No.?????
    By shawnmd in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-26-2010, 08:48 AM
  4. can someone give me some info on 95 speedster?
    By darrenz in forum 2-Stroke Performance
    Replies: 14
    Last Post: 03-30-2010, 09:30 PM
  5. Can someone help with engine break in?
    By Banks93 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-10-2008, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •