Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    2000 Seadoo GTX RFI starting issue warm

    Hi, My Seadoo RFI Millenium starts right up but when I run it in the lake and shut it off it will not start back up until it sets for about an hour and cools off??? Would this be the temp sensor?

    If so where is the temp sensor located, I can not find it..

    Thanks a million!


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    What, exactly, does it do?

    Will it turn over but not crank?

    Will it not turn over?

    Any messages on the MFD?

  3. #3
    It will spin like it is not engaging the starter. No message on the screen.

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Like the bendix is not coming out, right?

    Since that is part of the starter on that machine, what does that sound like?

  5. #5
    My mistake, it is turning the motor over like it should but wont start like it is not getting fire when warm or hot. If it sets about 30 minutes it fires right up??

    Thanks so much for any help

  6. #6
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Ok, you need fuel, compression, and spark.

    Compression is pretty much there or not so...

    You need to varify that you have fuel pressure and or flow and spark when it is does not want to start.

  7. #7
    So when it is cold all 3 (compression, fuel, spark) can be there but when it is hot one or all of these may not be there?

  8. #8
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Fuel pump may be failing when it gets hot, or the coil, or the MPEM, or the pickup in the mag cover.

    When it runs, all three MUST be working. When it is cold, one or more of them MUST NOT be.

  9. #9

    forest

    Going to check on water hose and see if it will act the same. If it does will check spark first. Is there an easy way to check fuel pressure besides pulling fuel line? Thanks again and it may be tomarrow night before i can check these things.

  10. #10
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    my rfi just lost the fuel pump. one of the ways i could tell is to pull the injectors out. keep them on the fuel rail. ground out the spark plug wires of the grouding post and lay the fuel rail where you can see it. then hold the start button down and watch the injectors. make sure they both spray and stay spraying the whole time you hold the start button. mine would prime the line fine but not maintain it. ie..the injectors would spray for 2 secs then fade off to air. word of warning though, the pressure might pop the injectors off the rail when you are testing it. best to have a rag handy.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 Seadoo GTX 587 starting issue
    By hstrine3 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-28-2017, 06:15 PM
  2. 2000 seadoo gtx rfi newbie help please!!
    By ddnowens in forum 2-Stroke Performance
    Replies: 13
    Last Post: 07-14-2015, 09:09 PM
  3. 2000 Seadoo GTX RFI won't crank, just clicks
    By normr in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-28-2015, 08:50 AM
  4. 2000 gtx rfi starting issues
    By vodomagoo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2009, 01:06 PM
  5. Do They Make Performace Ride Plates for a 2000 seadoo gtx rfi?
    By jcohen17 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-09-2008, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •