Results 1 to 9 of 9
  1. #1

    RXP-X prop is binding in my 07 impeller housing...spacer?

    I am removing my 13/18 solas and replacing it with a rxp-x stock prop bent to 10/18.

    I had a little problem with having to grind down some edges on the new prop to get it to fit perfectly within the SS wear ring. No problem.

    However, now I am tightening the 12 mm allen to install the impeller and I am getting binding between the bottom of the prop and the housing.

    When the 13/18 solas is completely tightened in, I can still spin the prop freely inside the housing.

    Anyone else run into this issue and solve it with a spacer or griding down the bottom of the impeller?

    The prop without the concave design is the 13/18 and that one fits great - seems like maybe the "extra" around where the rxp-x threads on is the part that is binding. Please help.





  2. #2
    pretty please


  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Looks like you'r prop may be from a 09+ X boat and may be whats causing it to bind on the housing. It may not work. As for the diameter fitting tight, That is probably due to the pitch change.

  4. #4
    Quote Originally Posted by speedskixp View Post
    Looks like you'r prop may be from a 09+ X boat and may be whats causing it to bind on the housing. It may not work. As for the diameter fitting tight, That is probably due to the pitch change.
    Thanks for the reply. Can this prop work in a 2007 housing?

    In other words, is there a spacer or can I grind down the rear of the prop so it does not bind? Will either of those solutions cause problems of the blades being too close to to the rear of the housing or cavitation problems?

  5. #5
    any more prop experts or anyone who has maybe faced this issue have a solution? Please?

  6. #6

    Calling PROP experts - RXP-X prop in 07 impeller housing?

    The prop is binding between the base and bottom of prop for me. Do I just need to grind off a couple mm on the bottom, or is there a spacer you use to make these fit?

    Here is the rxp-x prop that is binding:




    Here is the bottom of the 13/18 solas that does not grind:


  7. #7
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    you might be able to just use a washer/spacer on the pump shaft.

    one of my setback props is so deap that is what i had to do to keep the blades from hitting the outer pump housing just right past the wear ring

    i think it was a bearing shim or washer, was a few bucks at local hardware store 3/4" ID 1.25" OD

  8. #8
    Quote Originally Posted by meeper View Post
    you might be able to just use a washer/spacer on the pump shaft.

    one of my setback props is so deap that is what i had to do to keep the blades from hitting the outer pump housing just right past the wear ring

    i think it was a bearing shim or washer, was a few bucks at local hardware store 3/4" ID 1.25" OD
    Thanks - I am grinding it down now. I have a mm more to go - 5 mm so far with a sharpening stone - man my shoulder is sore

  9. #9
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    just so you know...You are setting it back closer to the pump vanes. Many feel this will offer better acceleration anyway so it should not hurt anything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what will rxpx impeller do in my 07 rxp with x charger and 42's?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-19-2011, 06:32 PM
  2. RXP-X prop is binding in my 07 impeller housing...spacer?
    By Jim-C180 in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 04-29-2010, 06:46 AM
  3. Calling PROP experts - RXP-X prop in 07 impeller housing?
    By Jim-C180 in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-28-2010, 08:36 AM
  4. WTF is this in my IC?
    By Alex13 in forum 4-Tec Performance
    Replies: 41
    Last Post: 12-14-2008, 10:29 PM
  5. 2009 FXSHO is now in my garage!
    By LS2000 Cop in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 09-29-2008, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •