Results 1 to 10 of 10
  1. #1

    Question I cant work this out


    I had a great ride a couple of days ago and nothing unusual happened. I washed my Ski afterwards and noticed a bit missing (pls see the attached pics). Has anyone else had this happen? How would I fix it I wonder?


  2. #2
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    Doesn't look like your missing it. I bet it just slid forward.

    If you cant pull it back just pull it out and hammer it back in with a rubber mallet.

  3. #3
    Ahhh, I see. I'll try to push it back somehow.
    Thx.

  4. #4
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by Scotchmonster View Post
    Ahhh, I see. I'll try to push it back somehow.
    Thx.
    I don't think you can. Mine looks exactly like that.

  5. #5
    ABUDHABI boost your life's Avatar
    Join Date
    Dec 2009
    Location
    uae
    Posts
    95
    +1
    1

    hi

    mine same

  6. #6
    mmmm, this is annoying. It seems to be a bit of an "oversight" in the design

    Thx krispaintballz, you were right. I took the front thing off and slid it back again. There is nothing to hold it back though so I suppose it will just happen again I'll just have to get used to it as a little Yammy thing

  7. #7
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    Couldn't you just add a thin bead of silicone towards the back as "glue" and slide it back into position?

  8. #8
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    Quote Originally Posted by Scotchmonster View Post
    mmmm, this is annoying. It seems to be a bit of an "oversight" in the design

    Thx krispaintballz, you were right. I took the front thing off and slid it back again. There is nothing to hold it back though so I suppose it will just happen again I'll just have to get used to it as a little Yammy thing

    If you cant see it then I would order the trim on boats.net or even gpr stuff if it fits(might be cheaper) and cut it to length to fill the void. Then put the plastics back on. Be sure to keep about 1/8 to 1/4" gap for expansion. You can also at the end under the plastic drill a small hole through the trim and into the side rail and then put a small rivit in the hole. You can rivit it in or you can just epoxy it in too(might come out).

  9. #9
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    Quote Originally Posted by Kelly_A View Post
    Couldn't you just add a thin bead of silicone towards the back as "glue" and slide it back into position?

    That prob works too!

  10. #10
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by Kelly_A View Post
    Couldn't you just add a thin bead of silicone towards the back as "glue" and slide it back into position?

    16 penny nail should fix that right up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX 155- "Bogging 2000-4000RPM..." Cant figure this one out
    By ChrisFiore15 in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-19-2014, 10:37 AM
  2. I cant figure this thing out please help
    By hondarepoman in forum Honda How To & FAQs
    Replies: 35
    Last Post: 06-05-2010, 06:21 PM
  3. Replies: 4
    Last Post: 04-27-2007, 08:03 PM
  4. Bored? check this out... funny stuff
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 11-10-2005, 06:46 PM
  5. RXP BRAKES??? Check this out
    By Enufpwr in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-06-2005, 03:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •