Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303

    Gtx Pump DESTROYED! pics

    Friend of mine calls me and says his ski will not go ANYWHERE. Just revs and its leaking water into the hull. I told him to bring it by and we will put a new carbon ring in it. ( which i thought it was).

    When I pulled the pump i was confused as to what the hell has happend. At first I thought it was just the wear ring that was ate up. But then I realized it was still there and in good shape! When I went to remove the carbon ring it was gone . So was the hose clamp that held it in place! Looking at the pump Im guessing it sucked through the Thru Hull Fitting and into the pump? Now the pump is trashed and there is melted plastic all in it. When I grab the Cone I can twist the whole bearing housing back and forth in the plastic pump. It split the pump housing in half! The bearings are free and spin nice. This is somthing I havnt seen before.

    QUESTION: I have put a new carbon ring,steel ring and a new hose clamp in the ski now. Should the thru hull fitting be replaced? Even though with a new carbon ring no water can come in? Its kind of torn up from the old carbon ring coming thru it. ( See pics)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0891.jpg 
Views:	145 
Size:	3.20 MB 
ID:	185990   Click image for larger version. 

Name:	IMG_0892.jpg 
Views:	113 
Size:	2.80 MB 
ID:	185991   Click image for larger version. 

Name:	IMG_0893.jpg 
Views:	105 
Size:	2.66 MB 
ID:	185992   Click image for larger version. 

Name:	IMG_0894.jpg 
Views:	86 
Size:	2.02 MB 
ID:	185993   Click image for larger version. 

Name:	IMG_0895.jpg 
Views:	80 
Size:	1.85 MB 
ID:	185994  


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by ktyamaha36 View Post
    Friend of mine calls me and says his ski will not go ANYWHERE. Just revs and its leaking water into the hull. I told him to bring it by and we will put a new carbon ring in it. ( which i thought it was).

    When I pulled the pump i was confused as to what the hell has happend. At first I thought it was just the wear ring that was ate up. But then I realized it was still there and in good shape! When I went to remove the carbon ring it was gone . So was the hose clamp that held it in place! Looking at the pump Im guessing it sucked through the Thru Hull Fitting and into the pump? Now the pump is trashed and there is melted plastic all in it. When I grab the Cone I can twist the whole bearing housing back and forth in the plastic pump. It split the pump housing in half! The bearings are free and spin nice. This is somthing I havnt seen before.

    QUESTION: I have put a new carbon ring,steel ring and a new hose clamp in the ski now. Should the thru hull fitting be replaced? Even though with a new carbon ring no water can come in? Its kind of torn up from the old carbon ring coming thru it. ( See pics)

    I would think there has to be some way to repair the damage rather than replace the whole thing. Damn that's some serious damage to that pump.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by RX951 View Post
    +1

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    My guess is the guy LUBED the carbon ring. It is supposed to stay dry, and free of any lubricants. That, or, he ran it on the hose for a seriously long time and melted the carbon ring, from not dripping water on it. The wear ring is amazing.

    Now, the pump BEARINGS did fail. Look at how the aluminum sleeve twisted in the housing and busted the ears?

    Two different problems.

    If the thru-hull fitting is still sealed, don't worry about it. Get him a new pump, carbon ring, and degrease the SS ring if it isn't damaged too. Otherwise, get a new SS ring also.

  6. #6
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by 96XPSS View Post
    My guess is the guy LUBED the carbon ring. It is supposed to stay dry, and free of any lubricants. That, or, he ran it on the hose for a seriously long time and melted the carbon ring, from not dripping water on it. The wear ring is amazing.

    Now, the pump BEARINGS did fail. Look at how the aluminum sleeve twisted in the housing and busted the ears?

    Two different problems.

    If the thru-hull fitting is still sealed, don't worry about it. Get him a new pump, carbon ring, and degrease the SS ring if it isn't damaged too. Otherwise, get a new SS ring also.

    What do you think caused the bearings to seize?

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279

    my guess

    running on the hose too long..to many times. I only see damage like that aftr a major ingestion of "rock candy"

    Betcha it smells pretty nasty too.

    That's about $600 worth of nasty.

    prop looked amazingly good..they typicall have melted wear ring drizzeled all over it. tough to get off.

  8. #8
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    He did start it up every couple weeks and run it on the hose during the winter. He told me he never ran it for more than 5 mins but now today says he rev'd it quite a bit on the trailer..lol OOPS!!! Guess he will pay for that mistake!!

    I thought the bearings in the pump locked up also after I saw how it had twisted and broke the tabs off in the pump,but somthing had to get wedged in between the impeller and wear ring to cause that. ( Im thinking the missing hose clamp that held the Once in place Carbon ring). I checked over the bearings and they are nice and tight. No slop and spin freely! Who knows??

    If the thru-hull fitting is still sealed, don't worry about it. Get him a new pump, carbon ring, and degrease the SS ring if it isn't damaged too. Otherwise, get a new SS ring also.
    I already installed a new Carbon ring AND ss ring. Thru hull Fitting isnt cracked or anything just all chewed up around the edge. I figured it was ok. I am currently looking for a new (used) pump housing to throw back on it. I cant see him paying 300.00 for a new one on such an old ski. ( 1997)

  9. #9
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Question guys... Off the top of your head does anyone know if the pump off a 1998 GS with work on this this ski? Theres one on ebay for cheap!! And my buddys ski is a 1997 GTI with a 717 not a gtx like I thought it was!

  10. #10
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    97??? part it out.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XLT Bilge Pump Installation (Pics included)
    By PWCManiac in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 08-02-2011, 07:35 PM
  2. WTB:::: GTX Pump, Pics of what I need>>
    By xBigDaddyx117 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 11-08-2008, 03:46 PM
  3. 03 GTX pump vs. 04 pump
    By eckersjc2 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-25-2007, 03:58 PM
  4. Skat Modded GTX Pump
    By Pale Rider in forum 4-Tec Performance
    Replies: 21
    Last Post: 02-07-2006, 09:54 PM
  5. Pump sealing pics.
    By Pistonwash in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 01-17-2006, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •