Results 1 to 6 of 6
  1. #1

    experts please help!!!!

    Hello all, i have a 2008 rxp x with 25 hours on it, I just purchased it and took it out in the bay today for the first time, it ran mint, very quick and great handling, it has a air filter and free flow exhaust and a riva intake grit or something the guy said when i purchased it, after 30 mins I let it idle and went to punch it and the ski wouldnt accelerate as fast as it first did, so i drove it to shore and checked the grate, no sea weed present, I took it back out, it rode ok but wouldnt accelerate likeit did at first, it reached 70 mph but it wasnt a fast accel, what could be possibly wrong, i figure im going to take it out thursday and if im not getting the same amount of power like i did this morning at first im gonig to bring it to the dealer, pleasse help!!!!


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by mfdkhoff261 View Post
    Hello all, i have a 2008 rxp x with 25 hours on it, I just purchased it and took it out in the bay today for the first time, it ran mint, very quick and great handling, it has a air filter and free flow exhaust and a riva intake grit or something the guy said when i purchased it, after 30 mins I let it idle and went to punch it and the ski wouldnt accelerate as fast as it first did, so i drove it to shore and checked the grate, no sea weed present, I took it back out, it rode ok but wouldnt accelerate likeit did at first, it reached 70 mph but it wasnt a fast accel, what could be possibly wrong, i figure im going to take it out thursday and if im not getting the same amount of power like i did this morning at first im gonig to bring it to the dealer, pleasse help!!!!
    Im not an expert at this point but if It ran fine at first then stopped Im betting you ran it in the shallows and sucked up sand or debris and friend your wear ring.

    Easy to change with the right tools. Dont go to the dealer. They will charge you 500 bucks to do it!!

  3. #3
    loopierxp's Avatar
    Join Date
    Jan 2008
    Location
    Houma, Louisiana
    Posts
    141
    Welcome to the forum. I would have to agree. Does it sound like it is cavitating at all on take off?

  4. #4
    the ski sounds the same when taking off and idling, when it went up to 30 and stopped i though the grate was clogged, but nothing was in it, I didnt run it in the shallows, and im not sure where the wear ring is, im going to take it out now and ill let you know what i discover

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by mfdkhoff261 View Post
    the ski sounds the same when taking off and idling, when it went up to 30 and stopped i though the grate was clogged, but nothing was in it, I didnt run it in the shallows, and im not sure where the wear ring is, im going to take it out now and ill let you know what i discover
    It is the white plastic ring around your prop. Inspect it for excessive wear or grooves etc. Look all around that area for anything that looks abnormal.

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    What rpms are you seeing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 24
    Last Post: 05-06-2012, 12:54 PM
  2. No pressure from fuel pump EXPERTS Please Help!
    By jdjd in forum Polaris PWC Performance
    Replies: 6
    Last Post: 08-13-2011, 11:28 PM
  3. Jetting expert needed..help please
    By NJJer in forum Yamaha Old School Skis
    Replies: 27
    Last Post: 08-31-2009, 03:51 PM
  4. Open loop cooling experts- Please Help
    By Importracer in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-23-2009, 07:55 AM
  5. Prop experts, please help
    By engineermike in forum 4-Tec Performance
    Replies: 38
    Last Post: 04-27-2008, 09:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •